Ticket #144 (closed Defect: fixed)

Opened 7 years ago

Last modified 6 years ago

The case of the Disappearing Virtual Directories

Reported by: jbuzbee@… Owned by:
Priority: normal Milestone:
Component: Metadata - TV Show Version: 1.0b5
Keywords: Cc:

Description

I have a large collection of a particular show. When I enter its virtual directory under "TV Shows", I see "Season 1", Season 2", etc. Sometimes when I go into a "Season" directory, I get a listing of "<empty>" instead of the list of shows for that season. When I back out, using the menu key, the directory for that season disappears. If I restart the Finder, I can often go right back into my desired show/season and once again see the previously missing episodes. These files are accessed over an NFS mount, and they are also on a USB drive on the remote side. It is possible that the drive has spun down so that when they are first accessed, it may take a bit for the drive to spin back up - but I am not certain about this and I think I've seen this issue with other files that are not on an external drive on the remote side.

Change History

comment:1 follow-up: ↓ 2 Changed 7 years ago by gbooker

First of all, are you browsing all files, or a filtered list (unwatched, favorite)? The color of the gem next to the list title will tell you this.

Secondly, when these directories disappear, can the ATV see that they exist. You can test this by manually browsing to the directory they are contained in.

The virtual directories are only supposed to disappear if the files contained within don't physically exist.

comment:2 in reply to: ↑ 1 Changed 7 years ago by jbuzbee

I browse in the "all" mode. As far as the ATV seeing if the files exist, I'm going to have to wait until this occurs again to test, as I can't recreate it often. I'm starting to wonder if this problem isn't related to other NFS issues I've seen. I've been using a couple of different NAS boxes, accessing both via NFS from the ATV. And I sometimes seem to get into a mode where the ATV complains frequently about "Stale NFS file handle (70)" which I can't seem to diagnose (it happens on both NAS boxes, so it seems to be an ATV issue, not a NAS issue). So I guess if the ATV were in this mode, Sapphire would just drop the reference to the file/directory. Oh, and thanks for your work on this plugin. Even with my issues, it's great.

comment:3 Changed 7 years ago by gbooker

  • Milestone set to Awaiting User Feedback

Ah, the good ol' "Stale NFS file handle." I have have the joy (pain) of fighting that one on many OSs. It is not specific to the ATV by any means, it is just that NFS sucks, but there really is nothing that replaces it fully. Usually this is caused by a network interruption, but not always.

Yes, a stale NFS handle will cause this, because with a stale NFS handle, Sapphire cannot see the files any longer, so it things they have disappeared.

I'll leave this ticket open in case you find something else.

comment:4 follow-up: ↓ 5 Changed 6 years ago by smoldersonline

I'm running Sapphire on a Mac mini HTPC with the files on an external USB HD. With Beta 5 no problems at all (excellent product!!!). After upgrade to Beta 6, "Disappearing Virtual Directories" (without exception) after shut down of the Mac and HD. Any pointers would be appreciated.

In case I have misplaced this report (sorry) please let me know.

Thank you!

comment:5 in reply to: ↑ 4 Changed 6 years ago by smoldersonline

Replying to smoldersonline:

I'm running Sapphire on a Mac mini HTPC with the files on an external USB HD. With Beta 5 no problems at all (excellent product!!!). After upgrade to Beta 6, "Disappearing Virtual Directories" (without exception) after shut down of the Mac and HD. Any pointers would be appreciated.

In case I have misplaced this report (sorry) please let me know.

Thank you!

After deleting all Sapphire files from my Mac mini and a clean install of Beta 6 fixed the issue for me, it seems...

comment:6 Changed 6 years ago by gbooker

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone Awaiting User Feedback deleted
Note: See TracTickets for help on using tickets.