Ticket #156 (closed Defect: worksforme)

Opened 7 years ago

Last modified 7 years ago

Sapphire will not start, Mac mini running ATV4Mac in 10.4.11

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: Other Version: 1.0b6
Keywords: Cc:

Description (last modified by gbooker) (diff)

Apr 15 18:50:31 Mac-mini FrontRow?[310]: * NSEXCEPTION RAISED *

NSInvalidArgumentException: * -[NSCFDictionary setObject:forKey:]: attempt to insert nil value 0x9289c0ad: _NSDictionaryRaiseInsertNilValueException (in Foundation) 0x927df463: -[NSCFDictionary setObject:forKey:] (in Foundation) 0x170573bd: -linkCollections? (in Sapphire) 0x1705721a: -initWithFile:? (in Sapphire) 0x1705f3fd: -initWithScene:? (in Sapphire) 0x1705133b: -applianceController? (in Sapphire) 0x170517b1: -controllerForIdentifier:? (in Sapphire) 0x9e2c336d: -[BRApplianceBrowserControl controllerForCurrentSelection] (in BackRow?) 0x9e2d57f7: -[BRMainMenuSelectionHandler handleSelectionForControl:] (in BackRow?) 0x9e2d5716: -[BRApplianceBrowserControl(ListNotifications?) _categorySelected:] (in BackRow?) 0x927ef15b: _nsnote_callback (in Foundation) 0x908563d2: CFXNotificationPost (in CoreFoundation?) 0x9084d

Apr 15 18:50:32 Mac-mini loginwindow[84]: RCDClient.RCD_HandleHIDEvent: rcd_handlehidevent(): 0x10000003: (ipc/send) invalid destination port Apr 15 18:50:33 Mac-mini loginwindow[84]: RCDClient.RCD_HandleHIDEvent: rcd_handlehidevent(): 0x10000003: (ipc/send) invalid destination port Apr 15 18:50:34 Mac-mini loginwindow[84]: RCDClient.RCD_HandleHIDEvent: rcd_handlehidevent(): 0x10000003: (ipc/send) invalid destination port

Change History

comment:1 Changed 7 years ago by gbooker

  • Description modified (diff)

Reproduce this on leopard or the ATV to see if it persists there. ATV4Mac is not a supported platform.

comment:2 Changed 7 years ago by anonymous

Fixed by trashing preferences

comment:3 Changed 7 years ago by gbooker

  • Status changed from new to closed
  • Resolution set to worksforme

I suspect I know what caused this. If I am correct, the bug will be automatically fixed in the new architecture, so closing as works for me.

Note: See TracTickets for help on using tickets.