Ticket #190 (closed Defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Listings empty

Reported by: briangib@… Owned by:
Priority: normal Milestone:
Component: Other Version: 1.0b6.1
Keywords: Cc:

Description

Thanks in advance for any help. After importing my movies they list and play fine. The files themselves are located on an external USB2 drive.

However after shutting down both my Mac and drives, and restarting, when opening Sapphire, my movie list is then empty.

I have changed all filters, and metadata file is still there on my hard-drive, but yet not showing in Sapphire. Only option has been to reimport which is frustrating.

Any help appreciated!

Attachments

console.log.0 Download (9.6 KB) - added by argon@… 6 years ago.
Console log from recent crash
CrashReporter.log Download (252.3 KB) - added by argon@… 6 years ago.
Crash reporter log

Change History

comment:1 Changed 6 years ago by gbooker

  • Milestone set to Awaiting User Feedback

Is the drive mounted when you first start frontrow?

If you do re-import; sapphire remembers all your decisions; so it won't take as long and shouldn't need to ask you anything.

comment:2 Changed 6 years ago by briangib@…

Hi there, yes the drive is mounted when Front Row starts, and I have the direct link on the main menu to the volume also so can see the files are there. However, when I click the movies menu, it just comes up <EMPTY> on all filters.

Reimporting fixs it - until the next reboot that is....

comment:3 Changed 6 years ago by graham.mcluhan@…

I'm having a similar issue, my movies listing works fine but the TV shows listing does work. Every once and awhile it says something about the virtual directory and then goes to saying <EMPTY>. Tried reboots, no change.

comment:4 Changed 6 years ago by stephanelunsin@…

I'm having kind of a related problem. When importing the movies, some show up in the movie listing but others don't. It is dealing with a 500+ movie library but it worked fine before the upgrade to 6.3. Also TVShows sometimes show up, sometimes not. 2 External HD connected from boot. Any idea? Thanks

comment:5 Changed 6 years ago by gbooker

#210 marked as duplicate of this

comment:6 Changed 6 years ago by argon@…

Since around easter I have had a similar problem where at one point it started screwing up the virtual directories and most would be marked as <EMPTY>, eventually everything stopped working, I tried every available update from the SVN trunk, also reimporting didn't work, even after removing all Application Support files to start again. When the coredata branch appeared i attempted to use that, but before I did I completely reinstalled my tv from scratch and now Sapphire doesn't even appear to create it's MetaData? files or Settings plist, there is no Sapphire directory in Application support. Browsing collections directly results in <Scan for new files> appearing, if I manually create a Sapphire directory in Application Support then the settings.plist that appears is an empty XML file.

I'm running an apple tv with v2.1 and an external HD on USB, though the problem still occurs without the HD connected, I will also attempt to attach a copy of the console.log and Crashlog of the most recent crash

Changed 6 years ago by argon@…

Console log from recent crash

comment:7 Changed 6 years ago by argon@…

Forgot to mention, I'm running the latest revision from the SVN CoreData branch (659)

Changed 6 years ago by argon@…

Crash reporter log

comment:8 Changed 6 years ago by gbooker

What's in the "Library/Application? Support/Sapphire?" directory (including file sizes)?

comment:9 Changed 6 years ago by argon

'/Library/Application? Support/Sapphire?' is empty In '~/Library/Application? Support/Sapphire?' there is a metaData.sapphireData file which appears to be an empty sqlite DB with just the table setup and settings.plist which contains the following: <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-Apple ComputerDTD PLIST 1.0EN" " http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict/> </plist>

comment:10 Changed 6 years ago by gbooker

Likely a case where it doesn't handle creation of the metadata from scratch rather than upgrading it. That situation hasn't been tested yet.

comment:11 Changed 6 years ago by madbyte

I appear to have the same issue. I have +100 movies in a mounted directory. They seem to import fine, ~/Library/Application? Support/Sapphire? data files seems to hold the data, however the movie listing in Sapphire seems to not display all movies.

I cannot figure out why it displays only some of the movies and not others. Basically, all newly imported ones are not displayed, but are recognized on import. Could this be a permissions/ownership issue?

drwxr-xr-x 4 frontrow frontrow 136 Sep 7 22:28 Collection Art -rw-r--r-- 1 frontrow frontrow 629 Sep 30 23:31 tvdata.plist -rw-r--r-- 1 frontrow frontrow 55349 Oct 9 22:24 movieData.plist drwxr-xr-x 35 frontrow frontrow 1190 Oct 9 22:24 Poster_Buffer -rw-r--r-- 1 frontrow frontrow 402 Oct 9 22:26 settings.plist -rw-r--r-- 1 frontrow frontrow 70798 Oct 9 22:30 metaData.plist

comment:12 Changed 5 years ago by gbooker

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone Awaiting User Feedback deleted

This is old and should be fixed by now. Closing.

Note: See TracTickets for help on using tickets.