Ticket #191 (closed Defect: fixed)

Opened 6 years ago

Last modified 4 years ago

DVD folder error on play

Reported by: jrider@… Owned by:
Priority: normal Milestone:
Component: Playback Version: 1.0b6.1
Keywords: Cc:

Description

A couple of movies I have ripped to VIDEO_TS won't play through sapphire but play fine through Mac DVD Player. I've looked at the VOB file for these movies and compared them to those that work. The only difference is that the audio type for both moves is "unspecified". So I guess there is no default audio type written into the code??

Change History

comment:1 Changed 6 years ago by gbooker

  • Milestone set to Awaiting User Feedback

comment:2 Changed 6 years ago by fletch@…

Setup:

  • Sapphire b6.1
  • OS X 10.5.4
  • Mac Mini 1.83GHz

I may be experiencing the same bug. Sapphire is crashing around two VIDEO_TS rips. One troubling rip is "Unspecified" audio type. The other is "Spanish." (Probably my only two rips that are something other than "English," but I haven't verified that.) Both play fine in DVD Player.app. Both cause the generic "error has occurred" screen and an immediate exit of Front Row when I try to play them via Sapphire. Both also cause file scanning to hang until I kill ImportHelper. All my other rips work great.

This is is all I see in console. It looks like it shows up on FrontRow launch, so I doubt it's relevant:

7/16/08 11:17:55 PM FrontRow[7093] ******** Application Startup ********
7/16/08 11:17:55 PM Front Row[7093] +[SapphireAppliance className] called for 
    Leopard/ATV2 whitelist check, so I'm lying, m'kay?

Permissions are the same, and I can browse into the dirs in Finder.

What other information can I get you?

comment:3 Changed 6 years ago by wazza

I'm not sure why the playback crashes, because as far as I'm aware Sapphire delegates this directly to the DVD player.

As for the import problem this is most probably a bug in the VIDEO_TS parser. I'll see if I can hack an IFO file to report unspecified audio and if I can reproduce the import bug I'll raise a separate ticket for it.

comment:4 Changed 6 years ago by wazza

I have raised bug #207 regarding the import hanging, which was indeed as a result of incorrect handling of unspecified ISO codes in the DVD. I'm still not sure why Sapphire crashes during playback. Any further info would be welcome.

comment:5 Changed 6 years ago by gbooker

(In [647]) Applied patch Fixes #207 Refs #191

comment:6 Changed 6 years ago by cieplowski

I raised this in 221, sorry for duplication. HAve the same issue with several VIDEO_TS folders not playing. The only difference mentioned is that there is no other data against the movie aprart from the IMDB data. If I edit the plist and add the data it still crashes but only in Sapphire, normal movies in Frontrow play them fine. Will do some more testing but please let me know if there is anything secific I can pass on.

To add, the import process does not hang on these, just playing them causes problems.

comment:7 Changed 6 years ago by wazza

HI Mark,

First things first: make sure you have the latest version of Sapphire (6.3)

Second, if you have the latest version then make sure you've imported with that version. If you imported using an earlier version and are browsing with the latest then you're working with old metadata. The fact that you aren't seeing metadata for video or audio suggests this is the case.

Third, and this may be far too obvious but I'll say it anyway, are you sure you're not seeing video or audio metadata because you've selected the option in "Settings" to shut them off?

If, however, you have the latest version and have imported with the latest version and your settings should let you see this metadata then there is an issue. Can you attach an IFO file from one of the movies that has a problem? Navigate to the VIDEO_TS folder and choose the largest .IFO file (But not the one called VIDEO_TS.IFO) I'll have a look at it and see if I can find the problem.

comment:8 Changed 5 years ago by skyy99_1111@…

I was experiencing the exact same behavior (Mac Mini, Leopard 10.5.6, Sapphire b6.4) with a rip of The Chronicles of Narnia - Prince Caspian. After removing the subpicture (i.e. subtitle) that was of type "closed caption", Sapphire started playing the movie without crashing Front Row.

The other subpictures were categorized as caption - normal, caption - large, director's caption, etc. All in different languages. Once I removed the one categorized as "closed caption" (using dvd edit) the movie started playing fine.

Note, the movie played fine before removing that subpicture if I played it using DVD Player directly, just not through Sapphire.

Thanks, Matt

comment:9 Changed 4 years ago by gbooker

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone Awaiting User Feedback deleted

Sapphire has a different DVD playback mechanism now, so I'm closing this in anticipation that it resolves it.

Note: See TracTickets for help on using tickets.