Ticket #200 (closed Defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Import working (XML Files) but new TV Shows not showing in Front Row

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: Other Version: 1.0b6.1
Keywords: Cc:

Description

Been using Sapphire for a while and have seldon had problems.

But now I am having issues getting new shows to show up in Front Row. I've tried restoring back to good configurations (~Library/Application? Data/Sapphire? backups) and it still doesn't show up. I have been able to get movies to show up but not tv shows.

Any thoughts? Any other locations that Sapphire is getting configuration information from?

Change History

comment:1 in reply to: ↑ description Changed 6 years ago by rickp_ny@…

Replying to anonymous:

Been using Sapphire for a while and have seldon had problems.

But now I am having issues getting new shows to show up in Front Row. I've tried restoring back to good configurations (~Library/Application? Data/Sapphire? backups) and it still doesn't show up. I have been able to get movies to show up but not tv shows.

Any thoughts? Any other locations that Sapphire is getting configuration information from?

Replying with my email address in case anyone has any ideas, didn't mean to be anonymous.

comment:2 Changed 6 years ago by gbooker

  • Milestone set to Awaiting User Feedback

What do you mean specifically? State the process you go through when you add a new tv episode. Examples of filenames and xml files helps as well.

comment:3 Changed 6 years ago by smoldersonline

Same problem here. "Import All Data" & "Fetch TV Show Data" don't function properly (b6.1). The shows play OK, but (as of only a couple of days ago?) are not imported to and listed in the Virtual Directories.

comment:4 Changed 6 years ago by anonymous

Same thing here. Exactly the same problem. Suddenly it stops working a few days ago.

comment:5 Changed 6 years ago by caracos

I think the problem in ticket #200 and #201 caused by the same problem. I'm using 1.0b6.1. It worked flawlessly until a few days ago and suddenly it stop working. The problem is only with the "TV Shows". A new tv show doesn't show up. Then I did a clean install of 1.0b6.2 but the same problem occurred. TV Shows virtual folder showed <EMPTY>.

The only thing that I did to changed my system was installing the latest iLife update from Apple. Anything related to that?

comment:6 Changed 6 years ago by rickp_ny@…

I haven't installed the iLife update yet, so that's probably not it, but like the other posters it was working fine until a few days ago. As with the previous poster I was using the 2nd to latest beta which just stopped working, I tried updating to the latest but got the same results.

I am running out the door but if there is no resolution I will take a look at some XML backups and if there are discrepancies I will post it. But I can say the metadata is populating and viewable if I go directly to the folder, it's only in the "TV Shows" section where it doesn't show up.

comment:7 Changed 6 years ago by caracos

The only thing left is that the metadata for the latest TV Show that being pulled from TVRage is corrupted. Did TVRage changed something on their part?

comment:8 Changed 6 years ago by gbooker

#201 marked duplicate of this.

comment:9 Changed 6 years ago by anonymous

You're right, Gbooker... but I think the summary in 201 is more accurate (more clear, anyway). But, yeah, the sitch is that nothing shows up in the virtual TV folder, and the problem just started out of nowhere.

comment:10 Changed 6 years ago by gbooker

  • Status changed from new to closed
  • Resolution set to fixed

(In [640]) Correct fetching of title from TVRage's changed site.

Note to TVRage: Yes, we know you created these XML feeds for tools such as this, but until your feed actually contains the same information we already fetch, they are uterly useless to us.

Fixes #200

comment:11 Changed 6 years ago by anonymous

I'm sorry to be dense, but what does this mean? How can I get the TV shows to show up in the Virtual Folder again?

comment:12 Changed 6 years ago by sinful

In a nutshell, it means that the changes required to make the program operate properly have been made. Apparently, something in the pathing information was coming up incorrect, unless I miss my guess. I doubt that the TV Shows feature will work until a new build is made and released to the general public. Until that time, however, you can still access the information by going through the collections list from the main Sapphire menu.

Thanks for the work, gbooker. I know it's rarely said, but we all really do appreciate what you guys are doing here!

sin

comment:13 Changed 6 years ago by anonymous

Ah, I see. Wait for the next build. Okay, that's what I need to know!

Thanks, Sin, and THANK YOU, Gbooker, for such a fantastic application. As far as I'm concerned, Sapphire IS the Apple TV! As Sin said, there are those of us who REALLY appreciate what you do!

comment:14 Changed 6 years ago by gbooker

  • Milestone Awaiting User Feedback deleted

comment:15 follow-up: ↓ 16 Changed 6 years ago by anonymous

Any idea on how long it will take to put a new build out? I just spent several hours today reinstalling sapphire, deleting the metadata and reimporting (multiple times). Took hours because I have over 500 movies and about 15 tv series with all the episodes (3600+ files). And then I discovered this post! :)

comment:16 in reply to: ↑ 15 ; follow-up: ↓ 17 Changed 6 years ago by gbooker

Replying to anonymous:

Any idea on how long it will take to put a new build out?

When we feel like it.

comment:17 in reply to: ↑ 16 ; follow-up: ↓ 18 Changed 6 years ago by anonymous

Replying to gbooker:

Replying to anonymous:

Any idea on how long it will take to put a new build out?

When we feel like it.

How 'bout some instructions for those of us willing to do a build? As you can tell from all the duplicate defects reported, it's obvious this is affecting a lot of users and a pretty major break.

Is an AppleTV a requirement? When I tried doing a build it complained of missing BackRow?. When I tried installing it from  http://alanquatermain.net it told me I didn't have an AppleTV.

Thanks for any insight.

comment:18 in reply to: ↑ 17 Changed 6 years ago by gbooker

Replying to anonymous:

How 'bout some instructions for those of us willing to do a build?

 http://wiki.awkwardtv.org/wiki/Create_Environment_for_stock_ATV_1.1_Development_with_Leopard

comment:19 follow-up: ↓ 20 Changed 6 years ago by anonymous

Thanks Graham - appreciate you providing this. In my haste I blew away Front Row installing that (I guess the install had the files overwrite my Leopard files) so it looks like I need to figure out how to fix Front Row before I can continue looking to setup a build for Sapphire.

comment:20 in reply to: ↑ 19 Changed 6 years ago by anonymous

So I am still having this problem, any closer to a build being released to fix it?

comment:21 follow-up: ↓ 22 Changed 6 years ago by jason

I also have this problem, and it's very annoying. If the issue has been fixed, at least release a build! This is a major issue (none of my tv shows come up!), so if it has been fixed let us have what you devs have right now.

comment:22 in reply to: ↑ 21 Changed 6 years ago by gbooker

Replying to jason:

I also have this problem, and it's very annoying. If the issue has been fixed, at least release a build! This is a major issue (none of my tv shows come up!), so if it has been fixed let us have what you devs have right now.

We have, and stop being so demanding!

Note: See TracTickets for help on using tickets.