Ticket #206 (closed Defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

TV Show Season missing in Virtual Directory but information present from root menu

Reported by: Techlifter Owned by:
Priority: normal Milestone:
Component: Metadata - TV Show Version: 1.0b6.2
Keywords: Cc:

Description

I will start by saying that I have searched for this item to the best of my ability and, because it's not an error, per se, this is more behavioral than demonstrable with the console output. This installation of Sapphire is on an Apple TV running ver 2.1

Simply put,

I have all 4 seasons of BSG on a media drive that is mounted by nitoTV. I have been able to import all 4 seasons without a problem and each show from each season appeared in the TV Shows virtual directory and each were perfectly watchable.

Recently, I got to Season 2, ep 12 and the source file was an mpg, rather than an avi. Attempting to play it through sapphire would just cause the Apple TV to restart. Rather than mess with it, I simple got a new version of Episode 12 from Season 2 that was in AVI format.

After replacing the file, I went back to my Apple TV and started Sapphire. When I navigated to the TV Shows/Battlestar? Galactica/Season? 2, episode 12 was missing from the listing. I assumed that this was because I had just removed the previous source file (mpg) and replaced it with a new one (avi). As such, I just ran the TV importer again.

After running, the TV Show importer reported that 1 Entry had been updated. When I navigated back to to TV Shows/Battlestar? Galactica/Season? 2, episode 12 still did not appear. So, then I navigated to the Season 2 directory from the collections listing in the main menu and tried to "Mark All To Refetch TV Data" for the Season 2 and re-imported. Episode 12 still did not appear. Finally, I navigated to the Season 2 directory from the collections listing in the main menu and tried to "Mark All To Clear Metadata" for the Season 2 and re-imported. Now the BSG subdirectory in the TV Shows virtual directory only shows seasons 1, 3 and 4.

Even so, I can still navigate fro the collections listing and go to Season 2, which contains all episode information (including 12) and is perfectly watchable from there. This seemed to be a bug, so I was hoping to get more information.

Attaching my metaData.plist and tvdata.plist files in the hopes that they will be helpful in determining the problem.

Any explanation for this behavior and subsequent solution is welcomed.

Attachments

tvdata.plist Download (20.8 KB) - added by Techlifter 6 years ago.
tvdata.plist file
tvdata.2.plist Download (20.8 KB) - added by Techlifter 6 years ago.
tvdata.plist file

Change History

Changed 6 years ago by Techlifter

tvdata.plist file

Changed 6 years ago by Techlifter

tvdata.plist file

comment:1 Changed 6 years ago by Techlifter

Apologies, but the metaData.plist file was rejected by Trac fro being too large to include.

comment:2 Changed 6 years ago by gbooker

  • Status changed from new to closed
  • Resolution set to duplicate

This is actually a duplicate of #200 even though it doesn't look like it (the similarity is subtle). It is actually an error caused by tvrage changing their website layout. It was fixed in [640] and will be available in the next release.

comment:3 Changed 6 years ago by Techlifter

Ahhh, so it isn't something I'm screwing up. That's a relief.

Thank you so much, gbooker. As far as I am concerned, it was your work on Sapphire that finally got me to buy my Apple TVs. Your plugin and work therein are truly appreciated.

Note: See TracTickets for help on using tickets.