Ticket #218 (closed Enhancement: fixed)

Opened 6 years ago

Last modified 6 years ago

Allow folders to be marked as "TV" or "MOVIES"

Reported by: p.witty@… Owned by:
Priority: normal Milestone:
Component: Other Version: 1.0b6.3
Keywords: Cc:

Description

All of my content (prior to moving to Sapphire) was organized into to directories: TV and Movies. Since tv episodes never went into the movies directory and vice versa, importing data in Sapphire was extremely slow until I realized I should mark my movies directory to not import and then import my TV shows, then vice versa. At this point, I think I'm in a good position to add content and update my imported data fairly quickly and regularly as I add content.

BUT a big hurdle for new users is importing hundreds of gigabytes of content. Most people DO organize their content into folders "TV" and "Movies" (or at least most people I know do). This would be a great feature to assist people in their initial import, to be able to denote directories as "TV" or "Movies", then the import tool for TV would skip the movie folder(s) (and vice versa).

PS: I love Sapphire!! It is an AWESOME plugin!! You folks rock. Just fyi.

Change History

comment:1 Changed 6 years ago by gbooker

Why not just use the all importer?

The TV Importer will not attempt to do anything with a file whose name doesn't match one of the regexes. Then, failing to match the tv show import, it will attempt the movie, but not if it was previously identified as a tv show. I guess I don't see how this is a problem.

comment:2 follow-up: ↓ 3 Changed 6 years ago by p.witty@…

OK. So this brings me to my other bug I was about to open.

Using the "All Importer" fails on my AppleTV (running 1.1 firmware with Sapphire b6.3, with some content on the ATV and most content on external FAT32-formatted Drobo). It hangs as soon as it starts trying to import the first movie (regardless of what that first movie is). As soon as it completes the "Scanning" process and starts "Fetching"... I can leave it there for an hour, and it will stay on that first movie.

So I read somewhere that the "All importer" is just the 3 importers combined. So I tried running them separately. I found that it is the "Import File Data" that hangs. Which is why I run the TV and Movie importers separately. Now... if the "All Importer" is smart enough to not try to find a file's movie info when it has already been marked as a TV show... why isn't the Movie Importer smart enough to do that? And same question with the TV Importer? I can't even verify that what you are telling me is correct since the All Importer won't run properly!!

SO... if what you say is correct, then this could be changed to "Make individual TV and Movie importers as smart as the All Importer is (ie, don't try to get a file's movie info if it's already got TV info)."

comment:3 in reply to: ↑ 2 Changed 6 years ago by gbooker

  • Milestone set to Awaiting User Feedback

Replying to p.witty@gmail.com:

OK. So this brings me to my other bug I was about to open.

Using the "All Importer" fails on my AppleTV (running 1.1 firmware with Sapphire b6.3, with some content on the ATV and most content on external FAT32-formatted Drobo). It hangs as soon as it starts trying to import the first movie (regardless of what that first movie is). As soon as it completes the "Scanning" process and starts "Fetching"... I can leave it there for an hour, and it will stay on that first movie.

BugReporting You were told to follow these instructions when you opened this ticket.

So I read somewhere that the "All importer" is just the 3 importers combined. So I tried running them separately. I found that it is the "Import File Data" that hangs. Which is why I run the TV and Movie importers separately. Now... if the "All Importer" is smart enough to not try to find a file's movie info when it has already been marked as a TV show... why isn't the Movie Importer smart enough to do that? And same question with the TV Importer? I can't even verify that what you are telling me is correct since the All Importer won't run properly!!

It is.

comment:4 Changed 6 years ago by p.witty@…

OK. Look, let me open that ticket separately for clarity's sake.

I'm sorry -- your "It is" comment is unclear. Were you saying that as a response to my statement "I can't even verify that what you are telling me is correct", or in response to my statement "I read somewhere that the "All importer" is just the 3 importers combined"?

If the All Importer is simply the 3 different importer's run consecutively, then this enhancement ticket is to allow users to denote TV vs Movie collections (as first stated).

If the All Importer is BETTER and SMARTER than the separate TV and Movie importers, then this ticket is to enhance the TV and Movie importers so that they can be as smart as the All Importer.

comment:5 Changed 6 years ago by anonymous

The TV Importer will not attempt to do anything with a file whose name doesn't match one of the regexes.

The only problem here -- and I don't think it can be avoided in the TV importer -- is that Movies named with years (ie, "Surfs.Up.2007.xvid.avi") DO match the regex. Sadly I have MANY movies named like this... and I don't think the regex can be more specific or anything because it needs to account for TV shows that go into double-digit seasons.. so S##E##, ##x##, and #### should all be valid expressions for season-episode numbers.

Then, failing to match the tv show import, it will attempt the movie, but not if it was previously identified as a tv show.

OK I don't know why I thought this was incorrect before... but I just double-checked and verified that you are totally correct. I'm sorry I doubted you. :)

You can close this ticket. I'm really sorry. When I get home today I'll collect the necessary info for my data importer hanging issue and open a ticket for that... plus I have one more (hopefully better/more valid) idea for an enhancement... ;)

comment:7 in reply to: ↑ 6 Changed 6 years ago by gbooker

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone Awaiting User Feedback deleted

The "It Is" was in response to the all importing being a combination of the 3 importers.

Possibly the #### version of the regex can be made more specific; such as needing to be surrounded by spaces or periods (the others don't false-positive often). Several series, including a few among what the developers watch, have made it into their tenth season, but we don't label many movies with their year.

We found a case where the importer can hang, and it was corrected in [659]. In that case, if you experience the hang, and killing the ImportHelper? process corrects the hang, then it is already corrected. I'll mark this ticket as "fixed" (trac gives horrible choices on how to mark tickets) since it most closely matches the end result here.

comment:8 Changed 6 years ago by p.witty@…

We found a case where the importer can hang

How did you reproduce this? I simply try to use the all importer or the data importer, and it will hang. If I hit "Play/Pause?", it will scan again, then hang again the first time it reaches "Fetching...". I can repeat this ad infinitum. If I press "Menu" it returns me to the menu system.

I'll open another ticket, unless you'd rather me not. :)

Note: See TracTickets for help on using tickets.