Ticket #220 (closed Defect: invalid)

Opened 6 years ago

Last modified 6 years ago

Import All Data hangs

Reported by: p.witty@… Owned by:
Priority: normal Milestone:
Component: Other Version: 1.0b6.3
Keywords: Cc:

Description

I try to use the all importer or the data importer, and it will hang. If I hit "Play/Pause?", it will scan again, then hang again the first time it reaches "Fetching...". I can repeat this ad infinitum. If I press "Menu" it returns me to the menu system.

Please find logs attached.

Attachments

console.log Download (2.7 KB) - added by p.witty@… 6 years ago.
CrashReporter.log Download (596 bytes) - added by p.witty@… 6 years ago.

Change History

Changed 6 years ago by p.witty@…

Changed 6 years ago by p.witty@…

comment:1 Changed 6 years ago by gbooker

  • Status changed from new to closed
  • Resolution set to invalid

Your installation is corrupt. Download and reinstall. This is the second time someone reported this; how did you do your install?

comment:2 Changed 6 years ago by p.witty@…

I've already reinstalled once. I'll try reinstalling again, but I doubt it will work. I just followed instructions here:

http://appletv.nanopi.net/manual/install-atv/

My appletv was v1.0, but after patching shows "1.1" in "About". Also the crash report log showed many many instances of fsk causing crashes (divide by 0). Is any of this be relevant?

comment:3 Changed 6 years ago by gbooker

Are you decompressing the zip file on windows and then copying it over? If so, that's your problem; windows is completely incapable of handling a symbolic link with any intelligence. Use the self installer in the downloads page.

The divide by 0 crashes are not caused by anything we are doing and are indicative of a much more serious problem.

comment:4 Changed 6 years ago by p.witty@…

Yes, I was decompressing the zip file on windows... unzip binary on AppleTV wasn't there, and I didn't feel like finding a copy and scp'ing it over... didn't realize it would break Sapphire.

I tried running the install script, but it failed:

-bash-2.05b$ sudo ./Sapphire_1.0b6.3.sh
Password:
Verifying archive integrity... All good.
Uncompressing Sapphire 1.0b6.3...

Removing old Sapphire

Extracting Sapphire

ditto: Sapphire.frappliance/Contents/Frameworks/SapphireCompatClasses.framework/Versions/A/Headers/SapphireFrontRowCompat.h: No such file or directory
ditto: Couldn't read pkzip signature.
Unable to install Sapphire

I need to copy pkzip and unzip over, don't I? Argh that means I need to open up my 10.4 installer with Pacifist again... *sigh*... :(

comment:5 Changed 6 years ago by p.witty@…

As for the divide by 0 thing... I kind of suspect it is due to the fact that my external usb storage is Drobo... maybe fsk doesn't run properly on the Drobo...?

Or maybe it's just indicative of imminent HDD failure. I mean, with no active cooling, how long could the HDD of AppleTV really last? I presume it'll give up sooner rather than later...

comment:6 Changed 6 years ago by p.witty@…

OK well I finally stopped being stupid (like a month ago, almost right after my last post here), and just extracted Sapphire on my iMac, after which it worked quite beautifully.

Just makes me feel pretty sorry for people who don't have access to an OSX machine... because without one, I don't think that it would be possible to install Sapphire on an AppleTV.

Note: See TracTickets for help on using tickets.