Opened 6 years ago

Closed 6 years ago

#279 closed Defect (fixed)

Upgrade from 1.0b6.5 to 1.0b7 seg faulting

Reported by: wazza Owned by:
Priority: normal Milestone: Beta 7
Component: Other Version: 1.0b7
Keywords: Cc:

Description

Platform Leopard
Revision 808 on trunk and CoreData branches
FrontRow version 2.1.7

Desc When upgrading from an instance of Sapphire on the trunk the metadata upgrade runs ok, Sapphire reports that all of the upgrade has finished and then exits back to the main FrontRow menu. After 2-3 seconds FrontRow freezes and then quits out.

Reproduction Start with an existing 1.0b6.5 installation with non-empty metadata dir, install 1.0b7 and wait for automatic upgrade to finish running. In my case my content is a mix of AVI, MP4 and VIDEO_TS.

I've attached the crash log (in full, not sure what to leave out), the console gave nothing useful other than saying "Terminated"

Attachments (1)

Front Row_2009-04-06-090832_Sheila.crash (34.4 KB) - added by wazza 6 years ago.

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by wazza

comment:1 Changed 6 years ago by wazza

This is no longer seg faulting. (Probably due to [820]?)

I have a new problem now with metaData.sapphireDataV2 being created but destroyed straight after the upgrade, leaving me in a continual loop of running the upgrade everytime I open Sapphire. I'll dig around some more to see why this is.

comment:2 Changed 6 years ago by gbooker

  • Resolution set to fixed
  • Status changed from new to closed

(In [826]) Fixed upgrade that was broken previously.
This, and others,
Fixes #279

comment:3 Changed 6 years ago by wazza

Seg fault's back, I'm afraid. Same EXC_BAD_ACCESS error as reported in the original crash log and same issue, Sapphire upgrades, returns to the root menu and drops out after 2-3 seconds.

Not sure what else to report, if there's anything useful I can do from this side please let me know

comment:4 Changed 6 years ago by gbooker

  • Milestone set to Beta 7
  • Resolution fixed deleted
  • Status changed from closed to reopened

I'll look and see if I can reproduce it later

comment:5 Changed 6 years ago by wazza

I can no longer reproduce this, not sure what was going wrong or what was fixed, but it's not there anymore.

Can close, I guess.

comment:6 Changed 6 years ago by gbooker

  • Resolution set to fixed
  • Status changed from reopened to closed

OK

Note: See TracTickets for help on using tickets.