Ticket #292 (closed Defect: fixed)

Opened 5 years ago

Last modified 5 years ago

appleTV 2.1 with Sapphire Beta 7 - CoreData Preview

Reported by: chrislutz Owned by:
Priority: normal Milestone:
Component: Other Version: 1.0b7
Keywords: Cc:

Description

Hello,

upgrade database from beta 6.5 to beta 7 works fine.

But I have some other issues.

Import all Data don't work, if I press this item "Start Importing Data" it comes back with this Error message "press start/break to restart the appletv".

If I use in Settings the items fetch "TV Show Data or Movie Show Data" I have the same Error message.

DTS audio sources can now take advantage of passthrough <-- don't work, I use Perian 1.1.4 and ATV 1.2.1

Have you a idea to fix the issues?

Thx and greats

Attachments

console.log Download (10.0 KB) - added by chrislutz 5 years ago.
Logfile
console.2.log Download (10.0 KB) - added by chrislutz 5 years ago.
Logfile

Change History

Changed 5 years ago by chrislutz

Logfile

Changed 5 years ago by chrislutz

Logfile

comment:1 Changed 5 years ago by gbooker

For reference, it is throwing an exception on this line: source:branches/CoreData/SapphireFrappliance/MetaDataImporting/SapphireImporterDataMenu.m@782#L174

Anyway, it is saying that array has 0 items in it; a case we never imagined. We can fix it so it doesn't throw an exception, but that'll mean it won't import anything. So, if you go into the collections menu, does anything show up?

What is your setup when it comes to disks? Do you have external disks connected? Do you have disks mounted from other locations? Do you have a Movies directory in your home directory?

P.S. I deleted the previous ticket because it seemed like this was a duplicate of that one and this had the log files organized better.

comment:2 Changed 5 years ago by chrislutz

Hello, I have mount a timecapsule where all files saved.

timecapsule - wireless - Airport extreme - wired - ATV 2.1

comment:3 Changed 5 years ago by gbooker

(In [873]) Don't attempt to go through file scan if no collections are available. Refs #292

comment:4 Changed 5 years ago by gbooker

So, if you go into the collections menu, does anything show up?

Do you have a Movies directory in your home directory?

comment:5 Changed 5 years ago by chrislutz

Yes I can see all my movies or tv shows and can play this movies. In the collections menu are no entries.

The collections menu is the new menuitem or?

comment:6 Changed 5 years ago by chrislutz

Sorry my mistake, the collections are hidden have click the item and now I can search for new entries.

But the issues with DTS is not fixed. Have you a idea? I here nothing if I play a movie with DTS Movies with AC3 5.1 are working fine.

comment:7 Changed 5 years ago by gbooker

Sorry to say, DTS Passthrough was broken in Perian.  This changeset fixes it.

comment:8 Changed 5 years ago by chrislutz

Thx, for the fix but I'm a windows user, call you tell me how I can fix that or is that only with a mac possible?

comment:9 Changed 5 years ago by chrislutz

I mean can not call :-)

comment:10 Changed 5 years ago by gbooker

Only possible with a Mac. It requires using the development tools and building a new version from the source. Alternatively, you can wait for the next version, but I don't have an ETA on that.

comment:11 Changed 5 years ago by gbooker

  • Status changed from new to closed
  • Resolution set to fixed

(In [874]) Added ability to fetch all the collections which are not skipped instead of all the collections which are not hidden. Importer and Leopard File Events use non-skipped collections instead of non-hidden ones. Fixes #292

Note: See TracTickets for help on using tickets.