Ticket #294 (closed Defect: fixed)

Opened 5 years ago

Last modified 4 years ago

AC3 Passthrough not working on 1.0b7

Reported by: sapphire_user Owned by:
Priority: normal Milestone:
Component: Audio Version: 1.0b7
Keywords: Cc:

Description

I've done quite a bit of digging so apologies if needed info is missing or if this appears to be a duplicate.

I'm running Sapphire on ATV 2.3 Previously ran Sapphire 1.0b6.5 without problems and AC3 passthrough was working.

Installed update from 1.0b6.5. Update went without a hitch However once running 1.0b7, files encoded with latest ver. of Handbrake using AppleTV settings played no sound when AC3 Passthrough was enabled. Those files have an AAC track and an AC3 5.1/Passthrough track.

If I turned off AC3 Passthrough in Sapphire settings, I did get downmixed stereo.

However, HD video purchased through iTunes store continued to play 5.1 sound without problem in Sapphire.

When I played same Handbrake created files through NitoTV (Quicktime) they played 5.1 sound correctly.

When I initially upgraded to Sapphire b7 I was also running Perian 1.1.3. I upgraded to 1.1.4 without any luck. Downgraded back to 1.1.3.

On the off chance that meta data import was reading audio codec info incorrectly, I deleted my metadata file and reimported. No change with 5.1 playback.

I downgraded Sapphire to b6.5 and 5.1 now plays correctly.

I did read Ticket #292, however chrislutz appears to be having no issues with AC3 5.1 only DTS. I also read your comments and changeset 1121 regarding breaking Passthrough in Perian 1.1.4 and the subsequent fix, however, my problems continued after downgrading to Perian 1.1.3. AC3 5.1 Passthrough is working fine now in b6.5 even with Perian 1.1.4

I also looked at the console logs as suggested above, however, the only thing found in the tail was my Finder reboots after each troubleshooting step mentioned above.

If changeset 1121 will also fix the AC3 passthrough in addition to DTS passthrough, please feel free to delete this ticket.

Great update in all other respects - nice to see so many enhancements in a single update.

Thanks, Adam

Change History

comment:1 Changed 5 years ago by gbooker

  • Status changed from new to closed
  • Resolution set to fixed

(In [875]) Only attempt to disable audio tracks after the first is detected and abort if an AC3 track is encountered as disabling it breaks AC3 passthrough

comment:2 Changed 5 years ago by vmnrao

I am using Saphire 1.0b7p6 on AppleTV OS 2.4, Perian 1.1.4. AC3 passthrough is not working on several video files. Do you need me to post specific audio/video format information to confirm this is the same bug, or has this been fixed conclusively?

comment:3 follow-up: ↓ 4 Changed 5 years ago by gbooker

  • Milestone set to Awaiting User Feedback

This should be conclusive, but the information cannot hurt. Please provide the information as to what the container format is (.mov, .avi, .mkv, etc), which tracks are contained in the file (the fourcc info if you can get it, such as 'ac-3' or 0x6D732000), what exactly happens when you attempt to play it, and any other information that may be useful.

comment:4 in reply to: ↑ 3 Changed 4 years ago by vmnrao

gbooker- I'm sorry I was confusing AC3 with MPEG layer 3 audio, which does pose a problem for Sapphire but I've posted that in a new ticket. AC3 works fine for me so far. Sorry for the mixup.

comment:5 Changed 4 years ago by gbooker

  • Milestone Awaiting User Feedback deleted
Note: See TracTickets for help on using tickets.