Ticket #303 (closed Defect: worksforme)

Opened 5 years ago

Last modified 5 years ago

Can't delete collection in beta 7

Reported by: stuartleitch Owned by:
Priority: normal Milestone:
Component: Other Version: 1.0b7
Keywords: Cc: stuart.leitch@…

Description

Hi,

First, great tool, I love it!

Deleting a collection in beta 7 (AppleTV 2.4) doesn't work for me. I've tried it a few times (go into collections list, click play to add checkmark then menu to exit screen) with no joy. So I deleted everything in ~/Library/Application? Support/Sapphire?, and rebooted, but the rogue collection persisted.

Can you point me to where the collection list is stored? It would be good if it was in the above folder.

Finally, I'd suggest adding a "Delete selected collections" button rather than delete collections when clicking menu. For this kind of operation I'd like a strong positive confirmation.

Thanks again

Change History

comment:1 Changed 5 years ago by gbooker

  • Milestone set to Awaiting User Feedback

comment:2 Changed 5 years ago by stuartleitch

Following info present in Console, don't think it's relevant, but posted for completeness.

Can you post where the list of collections is stored please?

2009-08-18 08:00:00.001 Finder[452] *** _NSAutoreleaseNoPool(): Object 0x8bc7380 of class NSCFString autoreleased with no pool in place - just leaking
2009-08-18 08:00:00.002 Finder[452] *** _NSAutoreleaseNoPool(): Object 0x8bd39d0 of class NSCFString autoreleased with no pool in place - just leaking
2009-08-18 08:00:00.002 Finder[452] *** _NSAutoreleaseNoPool(): Object 0x8d312a0 of class NSCFString autoreleased with no pool in place - just leaking
2009-08-18 08:00:00.002 Finder[452] *** _NSAutoreleaseNoPool(): Object 0x8bb0250 of class NSCFString autoreleased with no pool in place - just leaking
2009-08-18 08:00:00.002 Finder[452] *** _NSAutoreleaseNoPool(): Object 0x8d61e80 of class NSCFString autoreleased with 
no pool in place - just leaking
2009-08-18 08:00:00.002 Finder[452] *** _NSAutoreleaseNoPool(): Object 0x8d60670 of class NSHTTPCookie autoreleased with no pool in place - just leaking
2009-08-18 08:00:00.002 Finder[452] *** _NSAutoreleaseNoPool(): Object 0x8b78fe0 of class NSCFString autoreleased with no pool in place - just leaking
2009-08-18 08:00:00.002 Finder[452] *** _NSAutoreleaseNoPool(): Object 0x19d9cf0 of class NSIdEnumerator autoreleased with no pool in place - just leaking
2009-08-18 08:00:00.003 Finder[452] *** _NSAutoreleaseNoPool(): Object 0x8bd5fd0 of class NSCFString autoreleased with no pool in place - just leaking
Aug 19 00:13:44 AppleTV reboot: rebooted by root

comment:3 Changed 5 years ago by gbooker

What is the path of this "rogue collection"? Is it a disk mount? Is it the Movies directory in your home directory?
Disk mounts collection can be deleting in that their metadata can be deleted, but collections for mounts (and the Movies directory if it exists) will be recreated. Sapphire automatically tracks all disk mounts, and this is done through its collections. If this is your case, most likely you are wanting to hide/skip import on this collection, but deleting causes it to completely forget this collection exists. Then a scan of mounted disks shows a disk it previously didn't know about, so a collection is created for it.
Otherwise:

If you browse into the collection after deleting it, are all the files missing their metadata?

Was that log from when you attempted to delete the collection?

Collections are stored in the CoreData database in that directory. Do not attempt to edit that database directly as it will cause a considerably larger number of problems if you do.

comment:4 Changed 5 years ago by stuartleitch

Hi,

I misunderstood how Sapphire was handling collections, so added a collection for ~/Movies/Drobo? which is a samba mountpoint for my Drobo on my mac mini.

So are you saying that Sapphire will automatically search for files in any mounted disks? Cool feature if that's the case, but probably should make folks aware of that. I guess I can move the mount point outwith ~/Movies to make things clearer.

I'll check whether files are missing metadata following deleting the collection and post that.

At the moment it's all working beautifully, so I'm loathe to touch much. When you say CoreData db in 'that' directory do you mean ~/Lib/App? Sup/Sapphire?? If so then it's probably the automount feature because I deleted everything in that folder when I uninstalled / reinstalled and the 'rogue' collection persisted.

Thanks for your reply

comment:5 Changed 5 years ago by gbooker

  • Status changed from new to closed
  • Resolution set to worksforme

Sapphire will automatically create a collection for each mounted disk. I've added it to the manual: http://appletv.nanopi.net/manual/getting-started/. Collections default to being displayed in the collection list and being imported. These can be changed for each collection in the settings menu.

There is no need to check if the data is deleted since I now understand why the collection is persisting. If it were not a mount, and it were still there, it would give a clue as to what is failing.

And yes, the CoreData database is stored in ~/Library/Application? Support/Sapphire?.

Anyway, closing since this is technically working as intended.

comment:6 Changed 5 years ago by gbooker

  • Milestone Awaiting User Feedback deleted
Note: See TracTickets for help on using tickets.