Ticket #308 (closed Defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Deleting last file in a Virtual Folder crashes Finder

Reported by: sapphire_user Owned by:
Priority: normal Milestone:
Component: Browser Version: 1.0b7
Keywords: Cc:

Description

gbooker,

I discovered a minor error in how b7 handles file deletions in Virtual folders. When deleting the last file in a virtual folder, Sapphire crashes to finder ("An Error Occurred. Press Play/Pause?" - or something very close to that). The file is successfully deleted, but apparently Sapphire gets confused now that the virtual folder shouldn't exist because no files populate it. I ran the tail command but no crash log was created. For completeness' sake, here's the tail:

Aug  8 23:47:45 kextd[42]: reboot/shutdown should have rebooted instead of dying
Aug  8 23:47:46 mDNSResponder: Removing browse domain local.
Aug  8 23:47:46 launchd: com.apple.nibindd: exited while shutdown is in progress, will not restart unless demand requires it
DNSServiceProcessResult() returned an error! -65537 - Killing service ref 0x1ba7d90 and its source is FOUND
Aug  8 23:47:47 launchd: com.apple.mDNSResponder: exited while shutdown is in progress, will not restart unless demand requires it
DNSServiceProcessResult() returned an error! -65537 - Killing service ref 0x8d0bad0 and its source is FOUND
DNSServiceProcessResult() returned an error! -65537 - Killing service ref 0x1b41f10 and its source is FOUND
DNSServiceProcessResult() returned an error! -65537 - Killing service ref 0x1bb4a10 and its source is FOUND
DNSServiceProcessResult() returned an error! -65537 - Killing service ref 0x1b90bd0 and its source is FOUND
DNSServiceProcessResult() returned an error! -65537 - Killing service ref 0x1bac220 and its source is FOUND

Change History

comment:1 follow-up: ↓ 2 Changed 5 years ago by gbooker

  • Milestone set to Awaiting User Feedback

Unless this really happened on Aug 8th, you Finder isn't logging. BugReporting has directions on resolving this. The exception it is supposed to log would really help in tracking this down.

comment:2 in reply to: ↑ 1 Changed 5 years ago by sapphire_user

I guess it was a good thing I posted the tail - seeing how I don't know today's date...

Here's another stupid question for you: Can't get the kill command to run properly -I get the following response when running this command in Leopard's terminal:

-bash-2.05b$ kill $(ps aux | grep -i [F]inder | awk '{print $2}')
kill: usage: kill [-s sigspec | -n signum | -sigspec] [pid | job]... or kill -l [sigspec]

I ran killall Finder and then "open /System/Library/CoreServices/Finder?.app" but it didn't correct the logging when I recreated the error. Still showing Aug 8 (which I now recognize is not today's date).

Any suggestions? Once I correct logging I will find the exception.

Adam

Replying to gbooker:

Unless this really happened on Aug 8th, you Finder isn't logging. BugReporting has directions on resolving this. The exception it is supposed to log would really help in tracking this down.

comment:3 Changed 5 years ago by wazza

Try either

ps aux | grep -i [F]inder  | awk '{print $2}' | xargs kill

or

kill `ps aux | grep -i [F]inder  | awk '{print $2}'`

comment:4 Changed 5 years ago by gbooker

  • Status changed from new to closed
  • Resolution set to fixed

(In [908]) Switched methods of checking isDeleted to objectIsDeleted since it is more trustworthy. If a directory object is deleted, flush all the info on it and pretend to be an empty directory so that the browser will pop. Fixes #308

comment:5 follow-up: ↓ 6 Changed 5 years ago by gbooker

FYI, this was a bear to track down. CoreData just loves to throw exceptions on deleted data (as it should), but doesn't want to let you know when an object has been deleted.

comment:6 in reply to: ↑ 5 Changed 5 years ago by sapphire_user

Confirmed fixed with Preview 5. Saw you found the problem before I got to fixing my logging issues. Great job stamping out these bugs so quickly. Kudos once again on a great program.

Replying to gbooker:

FYI, this was a bear to track down. CoreData just loves to throw exceptions on deleted data (as it should), but doesn't want to let you know when an object has been deleted.

comment:7 Changed 4 years ago by gbooker

  • Milestone Awaiting User Feedback deleted
Note: See TracTickets for help on using tickets.