Ticket #310 (closed Defect: worksforme)

Opened 5 years ago

Last modified 5 years ago

Partially watched files - setting to fully watched / unwatched

Reported by: frl Owned by:
Priority: normal Milestone:
Component: Metadata - Movie Version: 1.0b7
Keywords: Cc:

Description

Hi,

Not a biggie and I could be wrong, but I think the logic for setting a partially watched file to fully watched or unwatched is backwards.

If you open an unwatched file and immediately stop playback, it is correctly flagged as partially watched. If you then press right to access the menu for it, the "set watched state" option available is "Set to Watched". Conversely, if you watch a file almost to the end (say you stop playback when the closing credits appear) and access the menu, the option available is "Set to Unwatched".

In my experience if I have stopped playback a few seconds in, I am more likely to want to set the status to Unwatched, which requires two menu accesses - one to set it to Watched and then another to set it back to Unwatched. The reverse also applies when stopping playback a few minutes from the end of a file - in that case I'm more likely to want to set it to fully Watched, which requires two menu accesses.

Maybe it's a personal preference thing, but it seems backwards to me at the moment :)

Cheers

Chris

Change History

comment:1 Changed 5 years ago by gbooker

  • Status changed from new to closed
  • Resolution set to worksforme

The unwatched state is separate from the partially watched. A file can be partially watched and unwatched at the same time. The same holds true for watched.

If you watch part of the file, and then exit, as you say it is partially watched, but it is also still unwatched. So, it will still show up if you are browsing only unwatched files. Furthermore, when you stop playback near the end of the file, as in over 90% of the way through the file, Sapphire marks this as watched (presuming that you may have skipped the credits or something along those lines).

Lastly, the partially watched files present you with a menu to continue playback where you left off, or to go back to the beginning.

This is the intended behavior. Perhaps the indicator for partially watched needs to also indicate whether it is a watched file, unwatched, or favorite without overriding the gem icon entirely.

comment:2 Changed 5 years ago by frl

Ah, yes I hadn't thought about it as being seperate to the watched / unwatched states - makes sense now.

Perhaps if a file is partially watched there should be an option to remove the partially watched state and return the gem colour to whatever 'real' state it is in. I think that would work for both the "stopped playback a few seconds in" and "skipped the credits" scenarios.

comment:3 Changed 5 years ago by pd5rm

Same issue here. I check the first say 10 seconds of a movie to make sure it's the right one, but would prefer it not to get tagged as partially watched. Right, now going back to toggle it twice - 1) watched 2) unwatched to get the icon back to blue state.

Note: See TracTickets for help on using tickets.