Opened 6 years ago

Closed 6 years ago

#358 closed Defect (fixed)

1.0b7.8.1 Import crashes consistently

Reported by: skyy99_1111@… Owned by:
Priority: normal Milestone:
Component: Metadata - Movie Version: 1.0b7.5
Keywords: Cc:

Description

Running on Mac Mini, Leopard 10.5.8. Upgraded to 1.0b7.8.1 and FR crashes during Sapphire import (doesn't matter which importer). Crash report is attached. There are several different crash reports, but this is a common error in many of them:

Application Specific Information:
* Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '* -[NSCFArray replaceObjectAtIndex:withObject:]: attempt to insert nil'

Attachments (3)

Front Row_2010-03-01-200021_LivingRoom.crash (53.4 KB) - added by skyy99_1111@… 6 years ago.
Front Row_2010-03-01-205200_LivingRoom.crash (45.9 KB) - added by skyy99_1111@… 6 years ago.
Front Row_2010-03-01-215749_LivingRoom.crash (46.7 KB) - added by skyy99_1111@… 6 years ago.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by skyy99_1111@…

Changed 6 years ago by skyy99_1111@…

Changed 6 years ago by skyy99_1111@…

comment:1 Changed 6 years ago by gbooker

Only the first is in Sapphire's code; the rest are caused by something else; likely a memory corruption. The first does not contain information about where the exception was thrown, so I have to guess.

comment:2 Changed 6 years ago by gbooker

  • Resolution set to fixed
  • Status changed from new to closed

(In [1198]) Make sure the data is not nil before replacing it in an array.
Fixes #358

Note: See TracTickets for help on using tickets.