Ticket #366 (closed Defect: invalid)

Opened 4 years ago

Last modified 4 years ago

nonstandard umask and .sh install breaks install

Reported by: sardion Owned by:
Priority: normal Milestone:
Component: Other Version: 1.0b7.8.1
Keywords: Cc:

Description

I have a "umask 027" in my .profile (I can't be alone on that). If I run the .sh installer, things get broken because permissions are wrong (apparently). Specifically, I get the Framework Error bug that is supposed to be fixed.

Changing umask to 022 (OS X default) before running .sh confirmed as fixing the issue. Maybe the .sh should set umask 022 before doing its thing?

Change History

comment:1 Changed 4 years ago by gbooker

  • Summary changed from nonstandard umask and .sh install breaks things to nonstandard umask and .sh install breaks install
  • Milestone set to Awaiting User Feedback

Did you try your proposed "fix" at all? The script runs a chmod, so I doubt that the umask change in the script will correct it.

comment:2 Changed 4 years ago by sardion

Alright, well I promise that when I did the install it was giving me the framework error and when I reran the script with umask change the error went away.

Looking at the script (if I read it correctly), I agree ... that can't matter. So I guess rerunning it was what fixed it.

Sorry for the confusion, I was trying to help.

comment:3 Changed 4 years ago by gbooker

  • Status changed from new to closed
  • Resolution set to invalid
  • Milestone Awaiting User Feedback deleted
Note: See TracTickets for help on using tickets.