Ticket #367 (closed Defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Fails to get TV data, fails to show TV files in

Reported by: timcrawf Owned by:
Priority: normal Milestone:
Component: Other Version: 1.0b7.8.1
Keywords: Cc:

Description

Similar to #364 the importer will freeze and state "Waiting for background import to complete: 0 URLs remaining to load." If I cancel and run again, it might process and it might not. Sometimes I am asked about shows, sometimes not. Either way, when I try to watch a show, it will have some, but not all of the shows. If I drop back to the main Sapphire menu, the try TV again, there will be less shows, or different shows, or one show called "undefined".

This is on Apple TV v3.0.2 with Sapphire 1.0b7.8.2 (1220). I had the issue originally on 3.0.1. I reset the Apple TV, reinstalled everything. The problem repeated. I removed Sapphire, removed the /Volumes/appleTV\ root/Users/frontrow/Library/Application\ Support/Sapphire?/metaData.sapphireDataV2 and metaData.sapphireDataV2-journal files. Reinstalled again and still the issue persists. Movies appear to import fine. The current try to import shows 506/983 imported, and "Waiting for background import to complete: 0 URLs remaining to load."

Relevant log entries, this repeats more often then quoted.

2010-05-07 09:47:41.002 Finder[353] *** _NSAutoreleaseNoPool(): Object 0x16f0f930 of class NSCFString autoreleased with no pool in place - just leaking
2010-05-07 09:47:41.002 Finder[353] *** _NSAutoreleaseNoPool(): Object 0xcc57df0 of class NSIdEnumerator autoreleased with no pool in place - just leaking
2010-05-07 09:47:41.002 Finder[353] *** _NSAutoreleaseNoPool(): Object 0x959e520 of class NSHTTPCookie autoreleased with no pool in place - just leaking

Yesterday when I was trying this there were also quite a few of these.

2010-05-06 22:19:55.188 Finder[353] Load of http://www.tvrage.com/shows/id-4972/episodes/142339/01x02 failed with error NSError "timed out" Domain=NSURLErrorDomain Code=-1001 UserInfo={
2010-05-06 22:19:55.189 Finder[353] Load of http://www.tvrage.com/shows/id-5220/episodes/157179/01x14 failed with error NSError "timed out" Domain=NSURLErrorDomain Code=-1001 UserInfo={

I just noticed that all Movie data is not correct either. For instance, while some of the movies show an oscar symbol while looking at "All Movies", when I select the category Academy Award Winning, I receive only <EMPTY>

Change History

comment:1 Changed 4 years ago by gbooker

  • Status changed from new to closed
  • Resolution set to fixed

[1134] and [1224].

Note: See TracTickets for help on using tickets.