Ticket #375 (closed Defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Upgrading problem

Reported by: phade Owned by:
Priority: normal Milestone:
Component: Leopard Version: 1.0b8.0.3
Keywords: Cc:

Description

Have problems upgrading from Beta 7.7 to b8.0.3.

First try: I just replace the code and kept the Metadata. Starting Sapphire just shows "Upgrading Metadata". After it was running for more than 2 hours (roughly 1700 files), I gave up. When escaping this mode, all collections where displayed two or three times (like / or mounted Volumes). Excluding and hidding them the normal way does not work, they stay in the list.

Second try: I removed all metadata-files and started from scratch. The importer did not realized already joined files and did ask me again for every part resulting in the parts AND the joined files being listed. Also it did not import all files (importer did not even ask for about 300 movies), even after several runs. They stay unseen.

Change History

comment:1 Changed 4 years ago by gbooker

  • Status changed from new to closed
  • Resolution set to invalid

No information about console. Failed to follow BugReporting instructions.

comment:2 Changed 4 years ago by phade

I followed the BugReporting instructions (ok, I did not state that there ARE no logs) ... So here you are again with more details:

There is no valig console output for the "first try", it just hangs and does nothing (except that the "wheel" is still turning, but I think, thats doing it forever, because its probably FrontRow? turning the wheel). A simple ESC ends that process returning to FrontRow?, so its NOT frozen, updating simply does not finished after a couple of hours ...

And there is no console output, because its a logical error:

  • why should the importer import parts of a file, when there are joined .mov files around with the same name ?
  • and there is no crash log or console log explaining why it only imports half the files ...

console IS empty in both cases ...

comment:3 Changed 4 years ago by gbooker

why should the importer import parts of a file, when there are joined
updating simply does not finished after a couple of hours ..

Where do you think the information about joined files is stored? Consider your two statements above, and my question, and you have your answer.

I removed all metadata-files and started from scratch
There is no valig [sic] console output for the "first try"

So, there is zero information from which to reproduce this? Nothing changes.

comment:4 Changed 4 years ago by edalzell

I am using Front Row on Snow Leopard 10.6.4.

Here is the output from the Console. I am experiencing the same thing..just hanging on Upgrading Metadata...

6/28/10 11:21:09 PM	Front Row[158]	Exception: NSInvalidArgumentException *** -[NSCFArray insertObject:atIndex:]: attempt to insert nil
 0x93859B9D 0x97FAC509 0x938598E8 0x9385985A 0x975D1532 0x97525199 0x9752511B 0x1204B9FF 0x12054DBE 0x1205A4C2 0x975378D4 0x97537884 0x909AC81D 0x909AC6A2
0x93786000	/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
0x97FA2000	/usr/lib/libobjc.A.dylib
0x97521000	/System/Library/Frameworks/Foundation.framework/Versions/C/Foundation
0x12000000	/System/Library/CoreServices/Front Row.app/Contents/PlugIns/Sapphire.frappliance/Contents/MacOS/Sapphire
0x9097E000	/usr/lib/libSystem.B.dylib

comment:5 follow-up: ↓ 6 Changed 4 years ago by phade

Sure, if there is no database because of a new installation, there is no "clear" information about a joined movie. I recommend a solution based on the part and joined movie filenames. Currently I name parts with "moviename - CD1.avi", "moviename - CD2.avi" aso, resulting in the joined movie filename "moviename - CD1.mov", what is kind of complicated. What if sapphire requires parts to be named "moviename.part1.avi" (or whatever extension), "moviename.part2.avi" aso ? Sapphire could then name the joined movie "moviename.mov" and, after a fresh install find the right parts easily and import the .mov only.

About the hanging upgrade: I tried if again and still have nothing in the console, but the same effect than edalzell ...

Kind regards, Frank

comment:6 in reply to: ↑ 5 Changed 4 years ago by gbooker

  • Status changed from closed to reopened
  • Resolution invalid deleted

Replying to edalzell:

Here is the output from the Console. I am experiencing the same thing..just hanging on Upgrading Metadata...

Finally something useful; see next.

Replying to phade:

I recommend a solution based on the part and joined movie filenames.

Patches welcome.

Also, do not create new tickets talking about existing tickets. It is a waste of our time and shows lack of appreciation for our work. This is volunteer, and continuing in such an attitude will result in developers walking away.

comment:7 Changed 4 years ago by gbooker

  • Status changed from reopened to closed
  • Resolution set to fixed

(In [1294]) Apparently the cast/genre/director cache may not store all values (appears to be an inconsistent database). Save lookups by continuing to use cache, but fallback on a miss. Fixes #375

comment:8 follow-up: ↓ 9 Changed 4 years ago by phade

Reply to gbooker: excuse me for not knowing how to deal this ticket system. last time I could reopen the ticket, this time I couldnt, so I didnt know, if you could see the news, when the state of the ticket is still closed.

I really love and appreciate your work, sapphire is the best media solution if seen during the last years and I love to help wherever I can, please do not take my tickets critical, they are just to bring things forward or to give new ideas or to point out problems. About the patches: I only program in perl and php, programming a mac is far beyond my horizon ... the only thing I could help so far, was some German translation.

BTW: when is the next compiled version about to come out, so I can test, if its fixed ?

Kind regards, phade

comment:9 in reply to: ↑ 8 Changed 4 years ago by gbooker

Replying to phade:

BTW: when is the next compiled version about to come out, so I can test, if its fixed ?

When it's out. There has never been a better answer since there's no regular release schedule.

comment:10 follow-up: ↓ 11 Changed 4 years ago by phade

Hm, what about a newsletter I could subscribe to or any other notification ? Kind regards, Frank

comment:11 in reply to: ↑ 10 Changed 4 years ago by pmerrill

Replying to phade:

Hm, what about a newsletter I could subscribe to or any other notification ?

the best thing to do is just watch the RSS feed for our trac timeline... Here

comment:12 follow-up: ↓ 13 Changed 4 years ago by phade

Tried 8.0.4 today, still the same problem, upgrading process works through Movies and Directories very quick and hangs than with "Files" for ages. No console output at all. If I escape the process, I return to the main FronRow? menu. If I start Sapphire then for a second time, I see a couple of Collections, mostly / and all mounted network drives, but I excluded those with the older version.

It looks to me, as if the upgrading process does not just upgrades the active collections, but also ALL mounted volumes and this may cause the long time it takes (there are more than a million files on my network drives). Could that be the problem ?

Maybe it would help, if the upgrading process displays the file its currently working on ...

comment:13 in reply to: ↑ 12 Changed 4 years ago by gbooker

  • Status changed from closed to reopened
  • Resolution fixed deleted

Replying to phade:

Tried 8.0.4 today, still the same problem, upgrading process works through Movies and Directories very quick and hangs than with "Files" for ages.

Is this what it did the first time? You didn't say. From this I conclude that you actually saved the metadata, which begs the question, why you didn't mention this when I said:

So, there is zero information from which to reproduce this? Nothing changes.

to your comments:

I removed all metadata-files and started from scratch
There is no valig [sic] console output for the "first try"

This metadata file would be useful in diagnosing this.

It looks to me, as if the upgrading process does not just upgrades the active collections, but also ALL mounted volumes and this may cause the long time it takes (there are more than a million files on my network drives). Could that be the problem ?

Not even close. First, it does nothing of the sort, second even if it did, it wouldn't take hours.

Maybe it would help, if the upgrading process displays the file its currently working on ...

Waste of CPU for an already CPU expensive operation. Not to mention the fact that when something goes wrong, the information displayed is incorrect compared with the one that's the real culprit.

comment:14 Changed 4 years ago by phade

Its still the same for what I called the "first try" eg. upgrading. Sure there is the metadata from the old version (do you mean that with "you actually save the metadata" ?). Its hanging the same way. I didnt try the "second try" again with the new version (just because its far too much work to begin from scratch).

I like to attach the metaData.sapphireDataV2, but its nearly 6 MB and attachments are limited to 256KB, any other way to send you this ?

Kind regards, Phade

comment:15 Changed 4 years ago by gbooker

  • Status changed from reopened to closed
  • Resolution set to fixed

comment:16 Changed 4 years ago by phade

8.0.5 really fixed this upgrading problem, many thnx. All data is intact, Sapphire works perfectly now for me.

It might be noted, that upgrading to a newer version always adds another / Collection to the list, I have 5 / Collections now (wich need to be skipped and hidden). Other volumes like mounted network drives or the users movies-directory stay only one time in the list. Restarting sapphire again after an upgrade does not add another / collection, its only added once after a new version is installed. Maybe simply checking the volume list for duplicates will solve this problem.

There is no console output nor crash for this problem.

Note: See TracTickets for help on using tickets.