Ticket #57 (closed Defect: duplicate)

Opened 7 years ago

Last modified 6 years ago

Sapphire with External Hard Drive?

Reported by: gdb@… Owned by:
Priority: normal Milestone:
Component: Browser Version: 1.0b4.2
Keywords: Cc:

Description

Hello, I got a 500 GB external HD today as a gift and I have moved all my music and videos over to it already. This works fine for iTunes and for playing movies via an alias within the ~/Movies folder with Front Row. However, I seem to be running into a problem with Sapphire, it's accessing the ~/Movies folder, but not the alias itself. I can get around this by going to the volumes/Outside Looking In (My external HD) and then going to the movies folder, this shows all the movies, along with the cover art, but none of the rest of the meta data. If I go to import any sort of data it will register some of my songs and music videos as movies as they are all on the external HD, this is quite tiresome with almost 5,000 songs and almost 200 movies. Is there some way to get Sapphire to ignore all the .mp3 and other audio files? My movies are all either .avi or .mp4 with one .divx file. What I would really like is to be able to go to Sapphire's main menu and select Movies and have Sapphire look at the movies folder on my external instead of the ~/Movies folder. If that's not possible, is there some way to force Sapphire to ignore the .mp3 and .m4p files in my music folde so I may be able to reload the meta data for the movies without needing to click <This is not a movie> 4000+ times?

Oh, and I would just like to say that I love Sapphire and I use it regularly to watch movies on my 24" iMac and I would really like to be able to use it as easily with an external drive as I did with my internal.

Thanks, Garrett

Change History

comment:1 Changed 7 years ago by gbooker

  • Status changed from new to closed
  • Resolution set to duplicate

I read this 4 times, and I still don't fully understand what you are saying. From what I can tell, you are asking for a custom location for Sapphire to import. That's a duplicate of #15

comment:2 follow-up: ↓ 3 Changed 7 years ago by gdb@…

Okay, I didn't see that one when I was looking. How about getting my meta data back? Sapphire lost all of it when I moved my movies from my internal HD to my external. Is there some way to get this back without importing it all again? I've got dial-up here at home and importing takes awhile.

comment:3 in reply to: ↑ 2 Changed 7 years ago by gbooker

Replying to gdb@vcn.com:

How about getting my meta data back? Sapphire lost all of it when I moved my movies from my internal HD to my external.

There is absolutely no practical way to detect a file moved across file systems as being the same file. Due to this, when the move occurs, and Sapphire detects the files no longer present that were, the metadata is pruned. If you had moved them, and left a symbolic link in the original location pointing to the new one, the metadata is moved to the new location, but otherwise, there is no way around it.

Is there some way to get this back without importing it all again?

Nope. At least, you don't have to answer the questions again for your movies and tv shows, and it doesn't have to conduct searches for identified files.

comment:4 Changed 7 years ago by gdb@…

okay, thanks. Can't wait for the next beta to come out

Note: See TracTickets for help on using tickets.