Ticket #88 (closed Defect: worksforme)

Opened 7 years ago

Last modified 5 years ago

Sapphire doesn't start on appletv

Reported by: nick@… Owned by:
Priority: normal Milestone:
Component: Other Version: 1.0b4.2
Keywords: Cc:

Description

I copied Sapphire in the /System/Library/CoreServices/Finder?.app/Contents/PlugIns directory. Sapphire shows up in the appletv main menu yet when I click on it nothing happens. Please help!

Change History

comment:1 Changed 7 years ago by gbooker

  • Milestone set to Awaiting User Feedback

BugReporting

It was in the big red box on top of the form you filled out to make this ticket. Read it.

comment:2 follow-up: ↓ 3 Changed 7 years ago by anonymous

I have this exact same error. Did you ever get yours fixed in any way?

comment:3 in reply to: ↑ 2 Changed 7 years ago by gbooker

Replying to anonymous:

I have this exact same error. Did you ever get yours fixed in any way?

We cannot reproduce this, so how are we supposed to be expected to do anything unless someone gives us the information we asked for?

comment:4 Changed 7 years ago by anonymous

Okay. I have checked my console.log file using grep and there is no mention of Sapphire anywhere. No errors or anything.

Is there anywhere else that I can check for an error?

This isn't an isolated event though. There is a thread on it here:

 http://forum.awkwardtv.org/viewtopic.php?f=10&t=1096

And I have two apple TVs and it doesn't work on either one......

comment:5 Changed 7 years ago by gbooker

grep is unreliable because an error message may not include sapphire or anything else you may look for. Use tail (mentioned in the BugReporting document).

Despite all the reports on this, no one has yet to include any information that is useful. I mean, does clicking do nothing but the rest of the UI remain completely accessible? Does it freeze frontrow?

comment:6 Changed 7 years ago by anonymous

No, my apple tv does not freeze when I try to launch it. The UI remains completely accessible. It makes the click sound when it tries to run it and then nothing happens.

This was the final part of my log:

Feb 6 02:33:48 com.apple.SecurityServer?: securityd terminating due to signal 15 Feb 6 02:33:48 mDNSResponder-108.5 (May 24 2007 21:20:44)[42]: stopping Feb 6 02:33:48 launchd: com.apple.syslogd: exited: Terminated Feb 6 02:33:49 mDNSResponder: Removing browse domain local. Feb 6 02:33:49 launchd: com.apple.syslogd: exited while shutdown is in progress, will not restart unless demand requires it Feb 6 02:33:49 launchd: com.apple.mDNSResponder: exited while shutdown is in progress, will not restart unless demand requires it

However, nothing is added by attempting to run it multiple times and I believe those log file entries are from the last time I attempted to launch it.

I appreciate the help. Your software just seems excellent and since I'm using my Apple TV to manage my movie collection, I really want to be able to run it.

Is there anything else I can try? I've tried installing b4 and b5 from multiple sources (SCP, ATV loader, WGET over the console) and nothing works on either of my 2 Apple TVs.

Thanks!

comment:7 Changed 7 years ago by anonymous

PS: Since it never seems to even attempt to start, I feel like this might be a permissions error or something along those lines. Where can I look or where should I check permissions and such?

comment:8 follow-up: ↓ 9 Changed 7 years ago by pmerrill

make sure your apple tv user frontrow has a 'Movies' (/Users/frontorw/Movies/) directory, I recall this being a unforeseen issue in the past.

comment:9 in reply to: ↑ 8 ; follow-up: ↓ 10 Changed 7 years ago by anonymous

Replying to pmerrill:

make sure your apple tv user frontrow has a 'Movies' (/Users/frontorw/Movies/) directory, I recall this being a unforeseen issue in the past.

That was it!!! Thank you!

Why isn't this documented somewhere?!?!??!?!

comment:10 in reply to: ↑ 9 Changed 7 years ago by gbooker

Replying to anonymous:

Replying to pmerrill:

make sure your apple tv user frontrow has a 'Movies' (/Users/frontorw/Movies/) directory, I recall this being a unforeseen issue in the past.

That was it!!! Thank you!

Why isn't this documented somewhere?!?!??!?!

Because we didn't know it was an issue. Guess we'll have to look into it now.

comment:11 follow-up: ↓ 12 Changed 7 years ago by anonymous

i have this same problem and i do have a /Users/frontorw/Movies/ directory. Any other ideas...Thanks.

comment:12 in reply to: ↑ 11 Changed 7 years ago by anonymous

Replying to anonymous:

i have this same problem and i do have a /Users/frontorw/Movies/ directory. Any other ideas...Thanks.

I had the same problem, Saphire installed and showed up in apple tv menu, but clicking on it did nothing (it responded with an audio "click" response, but no new menu appeared).

Adding a "Movies" folder to /Users/frontrow (even though i have nothing in it) fixed the problem, i can now see the Saphire menu and all my other mount points...

comment:13 Changed 6 years ago by anonymous

I had problems with this too, figured it out myself though, I wish I had have read this a week ago! I was ready to give up.

comment:14 Changed 6 years ago by gbooker

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone Awaiting User Feedback deleted

Should be fixed now in Beta 6. Closing in anticipation of that. Reply if not.

comment:15 Changed 6 years ago by Mangaphreak@…

Actually I have the very same problem with beta 6...! I have posted it in the awkward forum as well, by the way...

Anyway, I _do_ have a /Movies directory in my frontrow directory, always did -- and yet it doesn't seem to work...!? Just as many other reported before, Sapphire shows up in the menu, I can click the menu entry and hear the "plonk" sound, but that's all that happens...!? I would like to provide more information, I just don't know where to look for it...!? No console or crashlog entries mention Sapphire at all...

comment:16 Changed 6 years ago by rafael.magu@…

I have been experiencing the same issue, and it started on my ATV after I upgraded to 2.02 (Safe update, of course). At first I thought it was a problem with the AppleTV, but I have installe b6.1 on my Leopard MBP and I'm getting the same issue: UI fully functional, yet Sapphire won't start.

Console wasn't very helpful, so all I could find was:

Jun 17 13:14:25 op410ent0001e3245a53 Front Row[3322]: Exception: 0x92AC614B 0x90E9E0FB 0x92AC5F2B 0x92AC5F6A 0x90FE4328 0x15BE420 0x15BE05E 0x15C5877 0x15B9D22 0xD84C5A 0x90FE854A 0x92A2D9BA 0x92A2DC93 0x90FE57B0 0x90FEEFF8 0xD84BAA 0xD82FA7 0xD82EAA 0xD82F13 0xD82EAA 0xD82DB2 0xD82D2B 0x5514E6 0xD82C8A 0xD82A9A 0x92A4C60E 0xD6CFDC 0x3638 0x598ABE\n0x90FDE000 /System/Library/Frameworks/Foundation?.framework/Versions/C/Foundation\n0xD5E000 /System/Library/PrivateFrameworks/BackRow?.framework/Versions/A/BackRow\n0x929DA000 /System/Library/Frameworks/CoreFoundation?.framework/Versions/A/CoreFoundation\n0x90E95000 /usr/lib/libobjc.A.dylib\n0x15B8000 /System/Library/CoreServices/Front? Row.app/Contents/PlugIns/Sapphire.frappliance/Contents/MacOS/Sapphire\n0x1000 /System/Library/CoreServices/Front? Row.app/Contents/MacOS/Front Row

(Sorry for the mess of the log, but Trac's code block did not work quite well on the preview, and it is indeed all in one line.)

Hope it helps.

comment:17 follow-up: ↓ 18 Changed 6 years ago by gbooker

Rafael, That's in code that will not be present in the next version.

Try moving (or deleting) Library/Application? Support/Sapphire?/metadata.plist and run it again. That will delete it's saved metadata, but should allow it to launch.

comment:18 in reply to: ↑ 17 ; follow-up: ↓ 19 Changed 6 years ago by rafael.magu@…

Replying to gbooker:

Rafael, That's in code that will not be present in the next version.

Try moving (or deleting) Library/Application? Support/Sapphire?/metadata.plist and run it again. That will delete it's saved metadata, but should allow it to launch.

You, sir, are my unofficial god as of now!

comment:19 in reply to: ↑ 18 Changed 6 years ago by anonymous

Replying to rafael.magu@gmail.com:

Replying to gbooker:

Rafael, That's in code that will not be present in the next version.

Try moving (or deleting) Library/Application? Support/Sapphire?/metadata.plist and run it again. That will delete it's saved metadata, but should allow it to launch.

You, sir, are my unofficial god as of now!

I partially retract that ;) as it did work on Leopard, but not on my ATV.

Anything else to suggest?

comment:20 Changed 6 years ago by anonymous

I don't think this should be marked as Fixed. I have tried everything suggested here but Sapphire still does not start on AppleTV v2 (safe update)

Sapphire appears in the front row menu but when it is selected nothing happens. The atv does not stop working, you can still navigate to other things and run other programs but nothing happens when you try to run Sapphire. I have tried all versions between b4 to b6.2 and none of them seem to work on the atv v2 anymore. I did have it working on atv v1.1

thanks,

comment:21 Changed 6 years ago by gbooker

Until someone provides some useful information, nothing will change. Asking us to fix something we cannot reproduce accomplishes nothing than to just waste our time.

comment:22 Changed 6 years ago by anonymous

What do you need from us so that you can reproduce the problem. Here is what I did.

  1. started with atv v1.1
  2. patchstick update.
  3. used the atv loader to load sapphire (worked great)
  4. preformed the safe update to atv v2.0.2
  5. started to load things again. not sure of the order but these are what I have
    • nitoTV
    • Couch Surfer
    • rtorrent
    • iScripts
    • ATVFiles
    • Sapphire

I first attempted to load the old Sapphire v4 (I think) to see if it would work in v2, i then tried to load v5, v6.1 and now v6.2 They all do the same thing, they show up in the menu, but when I click on them nothing happens. I all that I see is the atv led flash showing that it accepted the remote command.

I am not sure how to get the log dumps that I see others have provided, but I would be more then willing to do this if someone wants to point me to some directions.

thanks,

comment:23 follow-up: ↓ 24 Changed 6 years ago by anonymous

Here is the log data that is produced when I select sapphire from the atv menu and press play.

	0x924e1ec7: _nsnote_callback (in Foundation)
	0x908b7102: __CFXNotificationPost (in CoreFoundation)
	0x908b6f9e: _CFXNotificationPostNotification (in CoreFoundation)
	0x924dd1ac: -[NSNotificationCenter postNotificationName:object:userInfo:] (in Foundation)
	0x924dd12d: -[NSNotificationCenter postNotificationName:object:] (in Foundation)
	0x9e333df1: -[BRListControl(ScrollControl) _selectCurrentItem] (in BackRow)
	0x9e332fab: -[BRListControl brEventAction:] (in BackRow)
	...more...
Sapphire is at 0xA005000
Jul 25 22:05:28 AppleTV FrontRow[3353]: *** NSEXCEPTION RAISED ***\n	NSInvalidArgumentException: *** +[SapphireFrontRowCompat usingTakeTwo]: selector not recognized\n	0x925d1a83: +[NSObject doesNotRecognizeSelector:] (in Foundation)\n	0x925249a3: -[NSObject(NSForwardInvocation) forward::] (in Foundation)\n	0x90ac6c01: _objc_msgForward (in libobjc.A.dylib)\n	0x0a0129b8: -[SapphireApplianceController initWithScene:] (in Sapphire)\n	0x0a006c32: -[SapphireAppliance applianceController] (in Sapphire)\n	0x9e322201: -[BRApplianceBrowserControl controllerForCurrentSelection] (in BackRow)\n	0x9e333f67: -[BRMainMenuSelectionHandler handleSelectionForControl:] (in BackRow)\n	0x9e333e43: -[BRApplianceBrowserControl(ListNotifications) _categorySelected:] (in BackRow)\n	0x924e1ec7: _nsnote_callback (in Foundation)\n	0x908b7102: __CFXNotificationPost (in CoreFoundation)\n	0x908b6f9e: _CFXNotificationPostNotification (in CoreFoundation)\n	0x924dd1ac: -[NSNotificationCenter postNotificationName:object:userInfo:] (in Foundation)\n	0x924dd12d: -[NSNotificationCenter postNotificationName:object:] (in Foundation)\n	0x9e333df1: -[BRListControl(ScrollControl) _selectCurrentItem] (in BackRow)\n	0x9e332fab: -[BRListControl brEventAction:] (in BackRow)\n	...more...

I hope this is enough info for someone to be able to look into this problem as I really miss being able to use Sapphire.

thanks.

comment:24 in reply to: ↑ 23 Changed 6 years ago by anonymous

Sorry should have said that the the last two comments were from the same atv. (2nd comment has the logs for it)

comment:22 "07/23/08 19:04:49 changed by anonymous" comment:23 "07/25/08 20:09:25 changed by anonymous"

Replying to anonymous:

Here is the log data that is produced when I select sapphire from the atv menu and press play.

I hope this is enough info for someone to be able to look into this problem as I really miss being able to use Sapphire.

thanks.

comment:25 Changed 6 years ago by gbooker

Delete, or upgrade ATVFiles.

comment:26 follow-up: ↓ 27 Changed 6 years ago by anonymous

upgraded ATVFiles to the latest version v1.1.1 off the awkward tv site and sapphire will now start. thank you so much...

comment:27 in reply to: ↑ 26 Changed 6 years ago by anonymous

Replying to anonymous:

upgraded ATVFiles to the latest version v1.1.1 off the awkward tv site and sapphire will now start. thank you so much...

I can confirm that!!!!

comment:28 follow-up: ↓ 29 Changed 6 years ago by graham

Installed Sapphire earlier today, mounted my shares, downloaded metadata and did a reboot when this was since the system was becoming very unresponsive. Worked fine but then all of a sudden Sapphire will not respond to the clicking - makes a click sound but otherwise will not load.

Have tried everything suggested in this post, By the way am running the latest build version with ATV software 2.2

comment:29 in reply to: ↑ 28 ; follow-up: ↓ 30 Changed 6 years ago by gbooker

  • Status changed from closed to reopened
  • Resolution fixed deleted
  • Milestone set to Awaiting User Feedback

Replying to graham:

Have tried everything suggested in this post, By the way am running the latest build version with ATV software 2.2

How about BugReporting?

comment:30 in reply to: ↑ 29 Changed 6 years ago by anonymous

Replying to gbooker:

Replying to graham:

Have tried everything suggested in this post, By the way am running the latest build version with ATV software 2.2

How about BugReporting?

Are snide comments, and duplicating bug reports really the way to get things done around here?

People are doing their best to report the problem, I myself have it - I have installed both the zip version and with the script on an ATV and I get a Sapphire menu, but when I click on it, and Sapphire in the sub-menu, nothing happens - it hangs my appletv and a killall Finder is required.

What more can we report, logs are bare, and I have just run your installation scripts - so please indicate, without being snide or offensive, how we can better report the situation.

comment:31 Changed 6 years ago by gbooker

This ticketing system is for our convenience. More than half the users reporting here fail to follow the BugReporting directions, which in turn wastes our time. The duplicate I suspect you are talking about could have been easily found in a search, and the resulting ticked answered his question. In both cases, providing a link to the required information/ticket is neither snide nor offensive, but rather the quickest method of pointing the user towards the required information/solution. You mentioned nothing about logs in your previous comment, so I must conclude that you didn't read BugReporting.

In short: do not take offense to anything here as responses are made quickly (which, BTW, is very typical of free/open source software).

I've added more instructions to BugReporting concerning the AppleTV not logging anything (yet another way in which the ATV's OS is broken), and what to do with a frozen UI.

comment:32 Changed 6 years ago by hwy101

Hate to be a buzzkill on what sounds like a great party environment but I too am having a problem getting Sapphire to start. Here is my info as requested for the bug report:

BugReporting:

1) Searched - found this ticket

2) Leopard 10.5.5 / Sapphire Browser (1.0B6.5) - installed both ways, last way was with the shell script

3) Log file:

1/9/09 2:03:37 AM Front Row[490] +[SapphireAppliance className] called for Leopard/ATV2 whitelist check, so I'm lying, m'kay? 

4) No crash - Front Row continues to operate - when selecting Sapphire, the menu click noise sounds but nothing happens.

I'm downloading and installing 10.5.6 now and will test it again and report back any changes.

Eric

comment:33 Changed 6 years ago by hwy101

Installed 10.5.6 - no change in bug status.

Eric

comment:34 Changed 6 years ago by gbooker

A thought that just occurred to me. Been a while since I've seen it, and I don't remember if it was fixed in the branch or the release, but do you have a "Movies" directory in your home directory. That may be preventing it from starting.

comment:35 Changed 6 years ago by hwy101

Yes - I saw that as a possible fix earlier in the thread and verified that the directory does exist in the proper location. I even tried creating a "Frontrow" user account to see if the scripts were linking to that account, but of course, that didn't change anything either.

I've checked all the permissions for the files and directories and everything seems to be in order. I've checked the ATVFiles version and it's 1.2.0 and installed and working fine.

Every other appliance I've installed works fine (that is supposed to work with Leopard Front Row): Couch Surfer, Files, Skype and it doesn't lock up, it just doesn't leave the main menu although I do see the nice film strip "S" icon to the left so some of the files are being read...

Just don't know what else to check or change and the only line that appears in the console log file is the one listed above...

Eric

comment:36 Changed 6 years ago by hwy101

PROBLEM SOLVED!

I have been scratching my head trying to figure out what else could be the problem and I think I finally figured out what was preventing Sapphire from starting!

I got clever with the Volume name on one of my external hard drives and named it: TV HD (that is the apple logo (Shift-Option-K), and the letters TV followed by HD. It got me thinking that maybe Sapphire was having a problem reading this volume with the special character in the name, so I just changed it to: ATV HD, and made sure I killed all processes, ran Front Row and voila!

So I would suggest you have users check to make sure there are no special characters in their volume names, and perhaps put support in the future for the Apple logo in the name 'cause I kinda like it :)

Eric

comment:37 Changed 6 years ago by gbooker

(In [741]) Correctly parse unicode mount points Refs #88

comment:38 Changed 6 years ago by anonymous

No special chars here - though I did find a reference to a metadata framework - but the framework looks incomplete.

I.e. the ref doesn't exist but there is a Versions/A directory - so it seems if this is part of Sapphire it isn't installing correctly.

comment:39 Changed 6 years ago by gbooker

Sapphire is self-contained. It doesn't need anything outside of it's bundle aside from what is already built into the OS.

comment:40 Changed 6 years ago by speediro

I had the same problem as described above. Sapphire just went clang.

Gave the command mount to see all mounted disks. and manually removed all unused disks.

-bash-2.05b $ mount /dev/disk0s3 on / (local, journaled) devfs on /dev (local) fdesc on /dev (union) <volfs> on /.vol /dev/disk0s4 on /mnt (local, journaled) WORKGROUP;xxx@192.168.1.2/TV on /mnt/Scratch/Volumes/tv (nodev, nosuid, mounted by frontrow) WORKGROUP;xxx@192.168.1.2/F on /mnt/Scratch/Volumes/f (nodev, nosuid, mounted by frontrow)


after that did a

umount /mnt/Scratch/Volumes/f and umount /mnt/Scratch/Volumes/tv

Retried sapphire and it starts again. Something must have gone wrong with the mounts.

Hope this helps

comment:41 Changed 5 years ago by gbooker

  • Status changed from reopened to closed
  • Resolution set to worksforme
  • Milestone Awaiting User Feedback deleted

Lack of useful information to continue investigation; closing

Note: See TracTickets for help on using tickets.