Opened 9 years ago

Closed 9 years ago

#151 closed Defect (fixed)

No AC3 passthrough

Reported by: carballoj@… Owned by:
Priority: normal Milestone:
Component: Settings Version:
Keywords: Cc:


I am currently running Sapphire Beta 6 on AppleTV Take 2. Was previously running Sapphire Beta 5 that was recompiled for Take Two and had the same problem. I am playing movies in m4v format from usb drive attached to AppleTV. I have Perian 1.1 installed. I cannot get AC3 passthrough on Sapphire but AC3 passthrough works perfectly on ATVFiles and NitoTV. I toggle the AC3 passthrough option in settings but problem is not solved. All metadata imported with no problem. I reinstalled Perian 1.1 but problem was not solved. Sapphire Beta 6 did not solve the problem.

Change History (8)

comment:1 Changed 9 years ago by carballoj@…

I deleted metadata files from users/frontrow/library.../sapphire and I re-imported all my movies to see if this would solve AC3 passthrough problem. Now I get no sound at all from receiver regardless of AC3 passthrough selection in the Sapphire settings. I do get sound from TV speakers with either AC3 passthrough setting. AC3 passthrough works perfectly with ATVFiles and NitoTV. AppleTV is connected to receiver via optical cable. Could it be that Sapphire has a problem directing AC3 passthrough via optical cable?

comment:2 Changed 9 years ago by gbooker

  • Milestone set to Awaiting User Feedback
  • What is the sample rate of the AC3 file?
  • Did this work before take 2?
  • How do you have the TV connected when you state you get sound through the TV speakers?
  • What is the sample rate of audio played on the receiver when it is played (assuming the receiver actually tells you)?

comment:3 Changed 9 years ago by carballoj@…

sample rate = 48 khz

did not use sapphire prior to Take 2

The TV is connected via RCA audio cable and component video.

My receiver does not tell me the sample rate (or I do not know where to look). It is a Yamaha receiver with dts. I can supply the model number if needed. The receiver is connected to AppleTV via optical cable. Movie files play in full digital surround (5.1) using identical hardware setup on ATVFiles and NitoTV.

I created movie file using HandBrake?. All movie files were created with the same rates and settings.

A possible hint. Before I erased metadata I had sound from the receiver using Sapphire but it was not 5.1, it was stereo. After I erased metadata and rescanned I initially got no sound from any of the speakers using Sapphire. I switched to a different movie and the sound suddenly started working form the tv but not the receiver. I went back to the original movie file with no sound and it had sound from the tv but not the receiver. From then on, all movie files played with Sapphire have sound with tv speakers but only with the tv speakers, not with the receiver.

comment:4 Changed 9 years ago by gbooker

Do you have A52Codec.component installed in /Library/Audio/Plug?-Ins/Components? ?

comment:5 Changed 9 years ago by carballoj@…

I believe I do have the A52Codec.component installed.

I have the following directory:


I believe I installed this component when I installed Perian 1.1 via NitoTV.

comment:6 Changed 9 years ago by gbooker

What happens if you turn the passthrough setting off in Sapphire?

comment:7 Changed 9 years ago by carballoj@…

I turned off the passthrough setting in Sapphire:

No sound from receiver.

When I turned on the tv speakers, there was no sound from the movie that was on the screen but sound returned to all movies after I switched to a different movie.

comment:8 Changed 9 years ago by gbooker

  • Milestone Awaiting User Feedback deleted
  • Resolution set to fixed
  • Status changed from new to closed

There was an issue with AC3 playback that was fixed a while ago; assuming that was it.

Note: See TracTickets for help on using tickets.