Ticket #100 (closed Enhancement: fixed)

Opened 7 years ago

Last modified 6 years ago

VIDEO_TS folders don't appear in Movies virtual dir

Reported by: antifuchs Owned by:
Priority: normal Milestone:
Component: Metadata - Movie Version: 1.0b5
Keywords: Cc:

Description

I notice that Sapphire b5 can now play DVD rips in the VIDEO_TS format. I like this feature a lot, but it doesn't seem to import DVDs in this format as movies: The importer doesn't ask me to select a movie title, nor do they appear in the "Movies" virtual directory. It's possible to play these titles by making the directory in which they reside a browsable collection, but I'd rather have them in the virtual directory itself.

I haven't seen crashes importing them yet, so there's no crash report. Beta5 hung indefinitely (got stuck at file 300/856 for 24 hours) trying to import these movies the first time I tried importing them, but I can no longer reproduce this, unfortunately.

Change History

comment:1 Changed 7 years ago by antifuchs

I forgot to mention that I'm using Sapphire on a Mac Mini running OS X 10.5.1; the movies reside on an external disk, in directory /Volumes/Media?/DVDs.

I made "DVDs" a collection (with import enabled), and hid/excluded from import its parent directory.

comment:2 in reply to: ↑ description Changed 7 years ago by banano

I have a similar set up, with my video_ts files in a folder \volumes\movies and the sapphire virtual folder doesnt pick them up. thanks!

comment:3 Changed 7 years ago by skyy99_1111@…

I had the similar 2 problems (crashing and not recognizing the DVD VIDEO_TS rips). I found that I needed to import the movies a small chunk at a time (say 100). First do a file scan, then get the movie info. Repeat.

I also found that if I renamed the DVD rip folder (that which contains the VIDEO_TS subfolder) to something like "My Movie.mov", beta 5 recognizes it as a proper movie and also still plays it using the DVD player.

comment:4 Changed 7 years ago by gbooker

  • Status changed from new to closed
  • Resolution set to fixed

(In [476]) Made VIDEO_TS containing dirs be movie candidates. Fixes #100

comment:5 Changed 7 years ago by ryang

This feature does not seem to work. I followed what was listed above but the only files that get recognized are my .mpg files. None of my VIDEO_TS folders are identified. Doesn't crash, just doesn't identify them as movies. This is an awesome feature and I look forward to trying this plugin again.

comment:6 Changed 7 years ago by RyanG

Should mention I'm running 10.5.2 on a Mac Mini and my VIDEO_TS folders are located on an afp mounted drive and it does appear as a collection in the plugin.

comment:7 Changed 7 years ago by gbooker

[476] is dated 02/02/08 11:11:08, and beta 5 was released before then.

comment:8 Changed 7 years ago by RyanG

Sorry if I missed something but I am running beta 5. Since I searched and found this ticket and it matches my issue, I posted under it. I tried the resolutions listed here but they aren't working. Should I open a new ticket?

comment:9 Changed 7 years ago by gbooker

I said, "beta 5 was released before then," so it stands to reason that beta 5 does not contain this fix. The bug has been fixed, but not in a release build.

comment:10 Changed 7 years ago by RyanG

Got it. Thx

comment:11 Changed 6 years ago by wazza

Are there pre-release candidates available for testing?

I checked out the subversion repository and attempted to build the trunk, but it failed due to missing Back row headers. Unfortunately back row also requires that I provide some Apple TV frameworks. As I don't have Apple TV this means I can't build anything, which is a pain.

Maybe I'm wrong but I'm guessing Sapphire and Back Row can only be built by users that have Apple TV and have access to the necessary internals? It's rather annoying I can't do this independently, which I know is neither your fault or problem, but a pre-release would be very welcome, I have nothing *but* VIDEO_TS folders, so currently Sapphire is just sitting there waiting to be used.

comment:12 Changed 6 years ago by gbooker

Wazza,

The build process requires nothing from the AppleTV. We weakly link to the frameworks, and in fact the developers link against the leopard framework, not the appletv framework. See the  Awkward wiki page for instructions on setting up the build environment.

comment:13 Changed 6 years ago by wazza

Thanks for the link, very helpful stuff in there.

I'm a programmer, but new to Objective-C, the Xcode environment, apple TVs, BackRow? Frameworks and programming on Macs in general.

Apart from that, it's all good :-)

comment:14 Changed 6 years ago by wazza

After a bit of fiddling I now have a version of Sapphire correctly handling VIDEO_TS.

I have created an enhancement (#145) for what I think might be a nice addition to this feature.

comment:15 Changed 6 years ago by RyanG

I'd be happy to do some testing for you. The VIDEO_TS feature is basically the whole reason I want to use Sapphire.

comment:16 Changed 6 years ago by wazza

Hi Ryan,

I don't know if the Sapphire team would appreciate me attaching non-release versions here, so I'll hold back on that.

If you have an SFTP or FTP site I could upload it to then I could do that for you. Alternatively create yourself a throwaway gmail address and I'll mail it there if you post the address.

comment:17 Changed 6 years ago by gbooker

Sapphire is an open source project (GPL), which means you can do what you like with it. You are allowed to release your own builds, or even branch your own code base, so long as the conditions of the GPL are satisfied.

As per other people's builds, just be aware that we won't support them, but we can't disallow them either.

comment:18 Changed 6 years ago by RyanG

That would be great if you could send it to rgaudet77@…. I realize it's not supported but I'm not concerned about that. It's just to tide me over until the next release. Thx.

comment:19 Changed 6 years ago by rcreff

So I am completely lost with the VOB issue. I ripped the disks. Sapphire sees them but comes up with meta data that has nothing to do with the movie. If I pick the wrong movie it shows up wrong but I can play it. Can you please help me with naming, meta data, and file format issues. I setup Sapphire for vob directories with ripped DvDs?.

Thanks, Rob Reff rcreff@…

Note: See TracTickets for help on using tickets.