Ticket #327 (closed Defect: fixed)

Opened 5 years ago

Last modified 5 years ago

1.0b7.6 (952) doesn't add any TV show info when importing.

Reported by: pd5rm Owned by:
Priority: normal Milestone:
Component: Other Version: 1.0b7
Keywords: Cc:

Description

The previous build (August 1st/Sapphire_1.0b7.CD.P6) worked fine with TV shows. I am not able to import ANY shows, including ones I know worked before (e.g. Mad Men).

I renamed the Sapphire directory in Application Support to test whether a clean run (I wasn't sure if the upgrade from a previous version broke something) and I still don't see any TV shows coming though. Movies work fine.

I've tried both manual and auto-tagging.

Attachments

Sapphire-1.0b7.6.zip Download (7.9 KB) - added by pd5rm 5 years ago.
1.0b7.6 Sapphire Application Support
Sapphire-1.0b7.CD.P6.zip Download (11.9 KB) - added by pd5rm 5 years ago.
1.0b7.CD.P6 Sapphire Application Support

Change History

comment:1 Changed 5 years ago by gbooker

  • Milestone set to Awaiting User Feedback

comment:2 Changed 5 years ago by pd5rm

Snow Leopard (10.6.2, but doesn't work on 10.6.1 as well).

No crash logs created.

comment:3 Changed 5 years ago by gbooker

  • Status changed from new to closed
  • Resolution set to invalid
  • Milestone Awaiting User Feedback deleted

User failed twice to provide log output. Giving up

comment:4 Changed 5 years ago by pd5rm

I'm not sure what else I can give you. Here are the steps I take.

1) I clean out my Sapphire metadata, and install Sapphire_1.0b7.6. 2) I've removed all files other than TV shows for testing purposes. 3) I deselect collections that I don't want scanned. 4) I select Import All. 5) I get prompts for TV shows (e.g Mad Men) and see it displaying the file name of the shows. 6) The import completes (i.e. no crashes). When I select the TV shows entry, there are no shows listed.

This is the console log (I can't see anything suspect here).

11/15/09 3:37:40 PM	FrontRow[13750]	******** Application Startup ********
11/15/09 3:37:41 PM	FrontRow[13750]	T:[0xa021a500] Registered BRPhotoPlayer for media type 3
11/15/09 3:37:41 PM	FrontRow[13750]	T:[0xa021a500] Registered FRITunesAppMusicPlayer for media type 0
11/15/09 3:37:41 PM	FrontRow[13750]	T:[0xa021a500] Registered FRVideoPlayer for media type 1
11/15/09 3:37:41 PM	FrontRow[13750]	T:[0xa021a500] Registered FRDVDPlayer for media type 2
11/15/09 3:37:53 PM	FrontRow[13750]	T:[0xa021a500] Start up render thread for display: 0xb414141
11/15/09 3:37:53 PM	com.apple.RemoteUI[13750]	CoreAnimation: rendering error 501
11/15/09 3:38:05 PM	Front Row[13750]	Save successful
11/15/09 3:38:06 PM	Front Row[13750]	Save successful
11/15/09 3:38:07 PM	Front Row[13750]	Save successful
11/15/09 3:38:19 PM	Front Row[13750]	Save successful
11/15/09 3:38:19 PM	Front Row[13750]	Save successful
11/15/09 3:38:19 PM	Front Row[13750]	Save successful
11/15/09 3:38:19 PM	Front Row[13750]	Save successful
11/15/09 3:38:19 PM	Front Row[13750]	Save successful
11/15/09 3:38:19 PM	Front Row[13750]	Save successful
11/15/09 3:38:19 PM	Front Row[13750]	Save successful
11/15/09 3:39:32 PM	Front Row[13750]	Save successful
11/15/09 3:39:34 PM	Front Row[13750]	Save successful
11/15/09 3:39:50 PM	FrontRow[13750]	T:[0xa021a500] Stop render thread

I'm also attached a zipped copy of Sapphire metadata directory for non-working Sapphire_1.0b7.6 and same run that works for Sapphire_1.0b7.CD.P6.

I deleted the artwork cache from the 1.0b7.CD.P6 (the other one did not have one).

Changed 5 years ago by pd5rm

1.0b7.6 Sapphire Application Support

Changed 5 years ago by pd5rm

1.0b7.CD.P6 Sapphire Application Support

comment:5 Changed 5 years ago by gbooker

  • Status changed from closed to reopened
  • Resolution invalid deleted

comment:6 Changed 5 years ago by gbooker

  • Status changed from reopened to closed
  • Resolution set to fixed

BugReporting states to include the output of the console and if nothing is in there to say so. This is here to determine who examined the console and who did not.

Only one piece of the import code has changed between CD.P6 (b7.5) and b7.6, which had an issue that's already been fixed... So I mark as fixed until the next release shows otherwise.

comment:7 Changed 5 years ago by pd5rm

It seems to be working on trunk.

1)After much frustration, I was able to get a build compiled. Not sure if this is the right place for this, but I needed to make some minor source changes to get a build on Snow Leopard (NSSize,CGSize changes) etc. Is this something I should send a patch for or I am doing something wrong?

2)Would it be possible to enable email notifications on trac ticket updates?

3)Finally, a big thanks for putting the time/effort into writing this software.

comment:8 Changed 5 years ago by gbooker

It already compiles on Snow Leopard; that's whee we build it:  http://wiki.awkwardtv.org/wiki/Create_Environment_for_stock_ATV_1.1_Development_with_Leopard

Note: See TracTickets for help on using tickets.